Sandbox Refresh Displaying Old Versions of Skuid pages

  • 1
  • Problem
  • Updated 2 months ago
  • In Progress
The last two times we have refreshed our sandbox, there are some Skuid pages that are displaying as older versions of the Skuid pages.  After refresh, Production Account Skuid Page != Sandbox Account Page, for example.  Anyone know what is causing this?
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
What was your version of Skuid before and after upgrade?

We haven't had any reportings of this prior. 
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb
Production Package:


Sandbox Package:

Sandbox Refresh:

Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Are versions saved on your page? Are you able to bring the page to the new version? I'm assuming the first picture is the desired result. Is that correct?
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb
That old version is from many months ago, maybe more than a year.  I haven't checked, but I assume that a version that old would not be kept?
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
The version that old may or may not be kept. Is the new one also available?
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb
Sorry, I thought I had included a shot of the desired result.  Here is the production version / desired result:

Photo of Mike Dwyer

Mike Dwyer

  • 3,390 Points 3k badge 2x thumb
Do you happen to have the old page versions in a different Module than the new versions? [You can guess where I've been burned before, although the symptoms were different.]
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb
It doesn't look like we have any pages in modules.  Granted, I am not positive I am looking in the right place
Photo of Mike Dwyer

Mike Dwyer

  • 3,390 Points 3k badge 2x thumb
You are looking in the right place for my curiosity. I would suggest clicking that Module:skuid selection on the upper right and see if any pages turn up there. What I am thinking is a situation where the same page name exists in No Module and in Module:Skuid.
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb
The only items in Module: Skuid look to be standard Skuid pages:
Photo of Mike Dwyer

Mike Dwyer

  • 3,390 Points 3k badge 2x thumb
Well, rules out that possibility.
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb
Thanks for the suggestion
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Have you brought over the pages in a page pack? Do you still have access to the finished/better pages? Does bringing them over directly - even if it is just copying and pasting the XML over - work?
Photo of Danny Hartley

Danny Hartley

  • 434 Points 250 badge 2x thumb
I have not brought them over in a page pack.  Is that something that needs to happen whenever we refresh sandbox?

I have access to the current pages in production.

Copy/pasting the XML works, but I was just trying to understand the root cause so that we can avoid having to copy/paste each refresh.