Rich Text Editor adds unwanted line spacing....

  • 1
  • Question
  • Updated 2 years ago
  • Answered
The rich text editor defaults to double spaced lines and I don't see a way to set it to single spacing. Am I missing something?
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Mansour

Mansour

  • 1,932 Points 1k badge 2x thumb
Try hitting Shift Enter.
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
Thanks, Mansour. I'll give it a try. Most applications that I use the editor for are best with single spacing. Seems like a setting that should be part of the standard controls.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Raymond,

I think what you're experiencing has to do with the CSS for <p>. As far as I understand, shift+enter will insert a <br/>, and enter inserts a new <p>. You might want to explore modifying the CSS for <p> within richtext components.
Photo of Allison

Allison

  • 360 Points 250 badge 2x thumb

Skuid rep helped us with this by adding CSS inline:


.nx-richtext-input p {

    margin: 0px;

    padding: 0px;

}



.nx-fieldtext p {

    margin: 0px;

    padding: 0px;

}

Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
Thanks! I used different CSS, but this is better than mine. Thanks for posting!