REST Model Not Working After MyDomain Update

  • 1
  • Problem
  • Updated 4 weeks ago
  • Solved
I created an Apex REST API to aggregate a bunch of record information and fed it to my Skuid REST model without any issues. Recently I made the MyDomain update that changed our internal SF domain. This has caused my model data to not be loaded anymore, giving me the error seen below:




I've tried updating my Remote Site settings, Connected App settings, Data Source and Authentication Provider to use my new domain; none of these have solved my issue. Does anyone else have any experience with this situation?
Photo of Eulogio Gallo

Eulogio Gallo

  • 1,874 Points 1k badge 2x thumb
  • sad

Posted 4 weeks ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
First of all, good call in doing the My Domain update --- you'll be in a much better place after this is all settled. 

If you copy the full URL for the popup and paste it into a text editor, you should be able to see a "redirect_uri" URL Parameter, can you paste that piece of it here? 

Also, can you grant login access to Skuid Support? 
Photo of Eulogio Gallo

Eulogio Gallo

  • 1,874 Points 1k badge 2x thumb
Thanks for the response! I included the entire URL and bolded the redirect URI parameter below:

https://thebroadcenter.my.salesforce.com/services/oauth2/authorize?client_id=3MVG9CVKiXR7Ri5qryWurzAUob859MdLYBaVI_wLqOT7OMoV3GZuE1DfLjO6XPh2QAoeWbRwy1niTlWZkhGl.&response_type=code&redirect_uri=https%3A%2F%2Fthebroadcenter--skuid.visualforce.com%2Fapex%2Fskuid__oauthcallback&state=%7B%22client_id%22%3A%223MVG9CVKiXR7Ri5qryWurzAUob859MdLYBaVI_wLqOT7OMoV3GZuE1DfLjO6XPh2QAoeWbRwy1niTlWZkhGl.%22%2C%22network%22%3A%22TBC_DDS%22%2C%22display%22%3A%22popup%22%2C%22callback%22%3A%22_hellojs_3s32ekbl%22%2C%22state%22%3A%22%22%2C%22redirect_uri%22%3A%22https%3A%2F%2Fthebroadcenter--skuid.visualforce.com%2Fapex%2Fskuid__oauthcallback%22%2C%22scope%22%3A%22basic%2Cfull%22%2C%22oauth%22%3A%7B%22version%22%3A2%2C%22auth%22%3A%22https%3A%2F%2Fthebroadcenter.my.salesforce.com%2Fservices%2Foauth2%2Fauthorize%22%2C%22grant%22%3A%22https%3A%2F%2Fthebroadcenter.my.salesforce.com%2Fservices%2Foauth2%2Ftoken%22%2C%22response_type%22%3A%22code%22%7D%2C%22oauth_proxy%22%3A%22https%3A%2F%2Fthebroadcenter--skuid.visualforce.com%2Fapex%2Fskuid__oauthproxy%22%7D&scope=full


I've also granted login access, let me know if you need anything else.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Eulogio, can you confirm that you have added this Callback URL to the list of Callback URLs in your Connected App?

https://thebroadcenter--skuid.visualforce.com/apex/skuid__oauthcallback
Photo of Eulogio Gallo

Eulogio Gallo

  • 1,874 Points 1k badge 2x thumb
That did it Zach, thank you so much!!

I originally had this URL which was working before the My Domain update: https://thebroadcenter--skuid.visualforce.com/apex/oauthcallback

Just leaving this here in case anyone else runs into similar issues.