Required fields are missing error but they are available.

  • 1
  • Problem
  • Updated 2 years ago
I get an error everytime I save an opportunity but the error doesn't stop the save because the fields are not actually missing. When I click on the error, It disappears. Any Help would be appreciated
Photo of Izunna

Izunna

  • 342 Points 250 badge 2x thumb
  • Confused

Posted 2 years ago

  • 1
Photo of Karl Li

Karl Li, Employee

  • 708 Points 500 badge 2x thumb
Izunna, do you have the fields checked as required from the Skuid page builder or from the Salesforce back end?
Photo of Izunna

Izunna

  • 342 Points 250 badge 2x thumb
From the Salesforce Back end. But these fields all have values for them and are not missing but I get the error.
Photo of Matt Brown

Matt Brown, Employee

  • 798 Points 500 badge 2x thumb
Izunna, the error disappearing when you click on it is just standard error behavior (it doesn't mean that the errors are gone).

Do you have any record create actions running? It's possible that there is another record being created in the background that is not being displayed, and so the errors being showed are related to that record. That's one possibility. 
Photo of Izunna

Izunna

  • 342 Points 250 badge 2x thumb
I looked through the actions for models to no avail. I decided to turn the Save/Cancel Button into two separate Buttons that did Save and Cancel respectively and I am no longer getting this error. I added the save/Cancel button at the side and the error came back again. There might be a bug here.
(Edited)