Removing Fields from one model removes render conditions from another

  • 1
  • Problem
  • Updated 7 days ago
  • Acknowledged
Hi,

We recently updated to the most recent version of Millau (version 11.2.12) and discovered an issue with removing fields and render conditions

Basically if you have one model for an object, for example Accounts, and have a render condition on a field/element etc that is for a specific field, for example, show 'Account Description' on a table if the field is not null. If you have a second model for Accounts ( even with a different name and not cloned or connected to the first model) that also has the Account Description field as a selected field, and then remove Account Description from the second model, it removes the render condition on the table for the first model.
Photo of Emma

Emma

  • 254 Points 250 badge 2x thumb

Posted 1 week ago

  • 1
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,504 Points 1k badge 2x thumb
Hi Emma, thanks for raising the issue! I will try to reproduce it and let you know the outcome :-)
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,504 Points 1k badge 2x thumb
Emma, I could reproduce the issue like you said, so I will report it to our dev team. Thanks again for informing us!
I could add the render condition to the field again and then it works. I'm sure you know that by know, just wanted to add this information for other users who might run into the same issue and find your community post.
Photo of Emma

Emma

  • 254 Points 250 badge 2x thumb
Thanks for getting back to me Luzie!

I also found I could remove the fields via the XML directly and it didn't remove the render conditions.
(Edited)