Related Records not showing properly In popup

  • 1
  • Problem
  • Updated 3 years ago
  • Solved

I'm having a weird issue, i cannot figure out

 

I have a popup action in a table , based on 2 different models: 

1-LoansOnBK (master)

2-Laon_payments (child)

 

When i create child records for LoansOnBk and save , they get created properly, as well as relationship field to parent gets filled automatically, but some reason except for 1st row on table , I do not see child records in popup 

 

So popup from company "2" (see below) shows at the bottom the field of child records(payment amount) as expected

 

But popup from company 3, does not show the child records at all , even though they exist (see 2nd SS below for classic SF view)

 



 

 

 

This table for child records has a context condition

 


 

So not sure what I'm missing honestly.

I would appreciate any help I can get

 

Thank you

Photo of Dave

Dave

  • 5,600 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Anna Wiersema

Anna Wiersema

  • 10,900 Points 10k badge 2x thumb
Hey Dave, just to double check, what actions are you running when you open the popup?  
I'm assuming you have at least these actions:
  • Activate and Set Value of a condition on the Loan Payments object where LoansonBK__c = {{Id}} (the Id of the master record of that row)
  •  Query Loan Payments should be set to Get more - merge in new records with old  instead of Standard - Complete Requery.
  • Show Popup  
Photo of Dave

Dave

  • 5,600 Points 5k badge 2x thumb
Hi Anna,

Thank you,

Atm i was not running multiple action, just a simple popup action

I tried what you explained above, but for the 1st action (activate and set model) I'm having an issue selecting the condition "=", for me the picklist always shows only 1 choice "none" when i click on it , so not really able to test it properly

Any idea why and what i can to fix it?

Photo of Dave

Dave

  • 5,600 Points 5k badge 2x thumb
Nvm , I got it, i had to set up a model condition filterable and call it from action.

And now it works.

Thx again Anna
Photo of Anna Wiersema

Anna Wiersema

  • 10,900 Points 10k badge 2x thumb
Yeah, so the first thing you need is a condition on your Loan Payments model on the lookup field to the LoansOn_BK object (it'll be called something like e LoansonBK__c ). Then set that condition's state to Filterable default off. This will allow you to manipulate it through the action framework and will make sure that when you open the popup for a row, it loads the Loan Payments related to that parent Loan.
Photo of Dave

Dave

  • 5,600 Points 5k badge 2x thumb
Actually I may have been a little to hasty in saying it works :(

Now all LoansOnBk records  show the same loan payments (from the 1st row)

here are SS of the steps I followed not sure where issue is

Here's condition filterable off



Here's 1st action:


and here's 2nd action

3rd is just popup

Now 2nd row on table 's popup instead of showing me the proper related  3 "loan payments" , it shows me those from 1st row
Photo of Anna Wiersema

Anna Wiersema

  • 10,900 Points 10k badge 2x thumb
A couple things:

  1. Remove that first condition from your model (the nonfilterable Advanced Loans on Bk = (LoansonBK) (Id)  because that's what's pulling in only the first row's payments.
  2. for your Activate & Set model condition - enter {{Id}} as the Value.
Photo of Dave

Dave

  • 5,600 Points 5k badge 2x thumb
For some reason ,with those changes, it now pulls all Loan payments record (not only related ones) for each row

btw if this will be simpler with a Screen share let me know

Thx
Photo of Anna Wiersema

Anna Wiersema

  • 10,900 Points 10k badge 2x thumb
Hm.... and you still have the context condition set?  so that in your popup  the LoansOnBK__C field = Id of record in context?
Photo of Dave

Dave

  • 5,600 Points 5k badge 2x thumb
Actually forgot to recreate that context condition on new popup, ty

But still I'm not able to see related payments records :(



Any way we can have a quick screenshare, i'm sure it's 1 little thing missing.
Or if you want I can Screencapture and post to youtube the whole thing

Let me know

Thx again
Photo of Anna Wiersema

Anna Wiersema

  • 10,900 Points 10k badge 2x thumb
Hey Dave, sorry for the delay in replying (#thanksgiving). Either way works fine for me. 
Photo of Anna Wiersema

Anna Wiersema

  • 10,900 Points 10k badge 2x thumb
Update: This issue is resolved. In the end, there was just a slight typo in the in the Activate & Set Value for Model Condition action - the proper value is {{Id}}