Red problem alert on Skuid page resulting from fields in a model which are inaccessible to a user

  • 1
  • Problem
  • Updated 8 months ago
  • In Progress
Hello!

We have a custom standard profile which is restricted from viewing a few fields on the Contact object. When such a profile views the Skuid page they get a problem error in Skuid referencing each of the fields. They only have the Skuid Page Viewer permission set.

Is there something we're doing wrong? A user shouldn't be getting errors just because a field is not accessible to them.

Cheers!

Louis

A Skuid Model, 'ContactRecord', requested a Field with relationship name 'VIP_Phone2__c', on the Contact Object, but Skuid could not find a valid Field accessible through this relationship name. Please check that this Field actually exists on this Object (or on any related Objects). If it exists, then ensure that the user has permission to access it. If it does not exist, remove it from this Model.
Photo of Louis Skelton

Louis Skelton

  • 5,626 Points 5k badge 2x thumb

Posted 1 year ago

  • 1
Photo of Louis Skelton

Louis Skelton

  • 5,626 Points 5k badge 2x thumb
That profile also seems to have access to view the "Edit Page" button and can view the underlying page but they get an error when trying to save any edits... So I must have done something wrong! Any ideas?
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 4,548 Points 4k badge 2x thumb
I think you just need to remove that field from the model/page if the user does not have access to it.

I got this same error a couple of weeks ago. It started popping up close to but not immediately after I had upgraded. In my case it was fields that the user did not actually need access (and the profile did not have read or edit access) but were fields that had been added to the page years ago and never used...so I just removed those fields from the page to get rid of the error.

It kind of made me crazy though as to why the error message would all of a sudden start throwing...so not saying I know the exact solution, but at least you're not the only one.
Photo of Louis Skelton

Louis Skelton

  • 5,626 Points 5k badge 2x thumb
I think that solution would work if I didn’t need other users on other profiles who do have access to that field be able to view that page and its fields. Surely the solution isn’t to maintain two separate Skuid pages? Either I’ve done something wrong or this is a bug!
Photo of Louis Skelton

Louis Skelton

  • 5,626 Points 5k badge 2x thumb
Hullo! Any thoughts on this from the Skuid camp?
Photo of Louis Skelton

Louis Skelton

  • 5,626 Points 5k badge 2x thumb
Polite bump! Any thoughts on how best to address this? This is now urgent.

It's on Skuid 11.2.11.
Photo of Louis Skelton

Louis Skelton

  • 5,626 Points 5k badge 2x thumb
Hello? I'm worried that my posts are hidden somehow? Is anyone there? Is this even real? Am I real?
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,632 Points 2k badge 2x thumb
If you've overridden all Lightning (or classic) access in terms of edit buttons and the like, you could just open up those field to that profile and render them away based on profile. I ran into issues like this with our Opportunity Creation page since I wanted to have a single page for all departments and that's the route I took. 

This will cause issues with Standard Reports though since those fields will now be visible to the users. But we opted to have reports driving export-only operations and skuid-based dashboards for all other use cases, so our users and managers don't create their own reports and never have to see a laundry list of unnecessary fields. 
Photo of Louis Skelton

Louis Skelton

  • 5,626 Points 5k badge 2x thumb
Hi Erik, thanks for the suggestion, but the issue with reports (and other non-skuid parts of the system) is inescapable.

Skuid should elegantly hide fields that User's don't have access to because of their Profile - just like Salesforce's standard page layouts.

Any response from Skuid yet? I'm still wondering if there's a setting I'm missing.
(Edited)