Question about [CORE-1715] - Aggregate Models Date Grouping - always uses UTC instead of localized time

  • 1
  • Question
  • Updated 3 weeks ago
  • Answered
I have a question regarding [CORE-1715]. I currently have a chart that shows Cases created by hour of the day (based on CreatedDate). I assume this change means that my chart will always show in UTC now instead of local time.

Is this true?

If so, how would I convert my chart to different time zones for different users?
Photo of Korey

Korey

  • 1,108 Points 1k badge 2x thumb

Posted 3 weeks ago

  • 1
Photo of Emily Davis

Emily Davis, Employee

  • 3,502 Points 3k badge 2x thumb
Hi Korey,
In your aggregate model, I'm assuming you have a grouping on a date/time field. On this model's settings, for the date/time grouping, there should be a new setting, "Convert to User Timezone", as of CORE-1715. Can you check if the property is checked or unchecked in the page composer?



If this property is checked, your users should see results grouped based on their current timezone, NOT UTC time. If the property is unchecked, your users should all results based on UTC time. Does this line up with what you're seeing?

Prior to CORE-1715, ALL users should have seen results grouped by UTC time; the ability to see these results by the running user's time zone is new as of that change.

If your experience is different than what I'm describing, please let me know!

Thanks!
Emily
Photo of Korey

Korey

  • 1,108 Points 1k badge 2x thumb
Thank you Emily!

This answers all of my questions, since it sounds like once I update from 11.2.5 I will gain the ability to convert it to different user time zones, and if I need to show it in UTC I can remove the check from this box.

Since I'm before CORE-1715 was implemented, that answers my follow up questions as well as why I don't see the checkbox. :)


Thanks again,
Photo of Emily Davis

Emily Davis, Employee

  • 3,502 Points 3k badge 2x thumb
Ah, yes, once you upgrade to 11.2.6 or higher, you should gain this capability. I had assumed you had already upgraded. Glad that helped!
(Edited)