Professional edition - PermissionsApiEnabled

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
Installed the skuid trial on salesforce professional edition and received the following error when trying to access skuid central: Invalid field PermissionsApiEnabled for PermissionSet.

Theirs only one admin user and all permission sets and a skuid license is assigned properly.

Please help.
Photo of mr. x

mr. x

  • 90 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Matt Small

Matt Small

  • 1,182 Points 1k badge 2x thumb
I know it sounds silly but have you checked the field permissions on the object? Also check that the object is "available" under the profile permissions for the object.
Photo of mr. x

mr. x

  • 90 Points 75 badge 2x thumb
Field permissions are good and object is available.
Figured out it was  API was not enabled since its the trial version.
Photo of mr. x

mr. x

  • 90 Points 75 badge 2x thumb
Had a talk with the Salesforce Manager and the question came up was"Does Skuid require API usage and how many API calls are needed?".
The AppExchange listing for Skuid stated that its compatible with the Professional Edition.

Any input?
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Our documentation revolving around how or when Skuid uses API calls can be found here:
https://docs.skuid.com/latest/en/skuid/deploy/salesforce/index.html