Process builder not running on record create from Skuid UI

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
We have two process builder flows that populate information on an Opportunity from the Account upon creation of the Opportunity. The process flows run fine from the standard SFDC UI but when we create them in the Skuid UI, they don't trigger. Bit of background - we're creating records from a wizard but as part of the process, the Account is saved and created before the Opportunity fields are presented in the wizard. Any thoughts as to why they don't want to play nice?
Photo of Matt Wyre

Matt Wyre

  • 230 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Your process builder, is it set to run on "only when a record is created".

Photo of Matt Wyre

Matt Wyre

  • 230 Points 100 badge 2x thumb
We've tested it both ways - "created" & "created or edited"
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
What about the criteria used? Can you provide screen shots of all the settings?
Photo of Matt Wyre

Matt Wyre

  • 230 Points 100 badge 2x thumb
Criteria:

Installer_Account__c is Null = True (lookup field on the Opportunity)
AND
[Opportunity].Owner.ContactID is Null = False

Immediate Actions:

Set Installer_Account__c to [Opportunity].Owner.Contact.AccountID
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Do you have this on?

Photo of Matt Wyre

Matt Wyre

  • 230 Points 100 badge 2x thumb
Still no dice even with it on...
Photo of Joe Ort

Joe Ort

  • 2,256 Points 2k badge 2x thumb
Why not just use formula fields on the Opp and point back to the account?  It's a child so it will work easily and that way you only need to maintain the data in one place.  Also, most reporting should be able to bring the account info onto an Opp report.