Problem with posting code in Skuid Community

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I have been seeing weird issue from yesterday in Skuid community Post Composer.
I use to see a button to format text to CODE, for showing snippets & page xml. But, i can't see anymore. But, i can see some people posting code.. So, can someone guide, if i'm missing something silly.. ?

i tried going into html  mode by clicking </> & typing code inside <code></code>   &  <code><pre></pre></code>  .. nothing works.. :(
Photo of Nepz Solutions

Nepz Solutions

  • 442 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Hello Sankaran -

The problem you are likely experiencing is a problem with the way the Operating System, browser and the "Get Satisfaction Community" handles the detection of "Touch enabled devices."  I had this same issue and my machine is not even touch enabled.  Intermittently, when I view the community I don't see the toolbar below the post area.  

I created the post https://getsatisfaction.com/getsatisfaction/topics/post-visibility-delayed-and-different-rtf-experie... for this issue.  Have a read through there to get the details.  Specifically, look at this post entry https://getsatisfaction.com/getsatisfaction/topics/post-visibility-delayed-and-different-rtf-experie... for what I found.

You'll want to make sure you disable touch detection in your browser completely and that should ensure you always see the toolbar.  If you are using Chrome, you can do this via the "chrome://flags" settings and then set "Enable touch events" to disabled.

Hope this helps!
Photo of Nepz Solutions

Nepz Solutions

  • 442 Points 250 badge 2x thumb
Hello Barry,

Thanks for quick response. unfortunately, that didn't solve the problem.


still, i can't see button for CODE format. I can see the same behaviour in IE11

At the moment, i can live with <pre></pre> tags in html mode.. so, not a big issue.. 
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Hello Sankaran -

Sorry that didn't help.  Possibly I misunderstood your original post.  To my knowledge, there has never been a "CODE" button, only a "PRE" button.

Do you see the "pre" button?  Do you see the toolbar at all under the textbox posting area?
(Edited)
Photo of Nepz Solutions

Nepz Solutions

  • 442 Points 250 badge 2x thumb
HI Barry,

yes, i see 'pre' button, it is for 'pre-formatted', isn't it ?     I remember there use to be a button, not sure what it is called, by clicking it will format the Source Code to 'block of code'(presumably wrapping it with <code/> & applying some styles)

For example, it will be like this, (i have taken a screenshot from someone's post)..   
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Hello Sankaran -

Gotcha.  The only button for this is the "PRE" button that you see, there's never been a "CODE" button that I'm aware of.

That said, the "pre" button should achieve what you are after.  If you paste in the text, select it and then click pre, it will make it look like the screenshot you just pasted.

Give that a shot and let me know if that's not what you are looking for.
Photo of Nepz Solutions

Nepz Solutions

  • 442 Points 250 badge 2x thumb
Hi Barry..

yes, As i said in my earlier comments, i use to press 'pre' button for the code portion of my message. But, it didn't work last 2 days.. 

Strangely, its working now.. :)  Thanks Barry for your replies.. 
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Sorry if I misunderstood Sankaran, glad to hear its working now though :)

I did notice that the community site was undergoing some maintenance over the last couple of days (I'd intermittantly get a "down for maintenance" message).  Possibly that was the culprit but difficult to say for sure.

Skuid uses the Get Satisfaction third-party service to host the community so there isn't much Skuid themselves can do when there are issues with the community itself.  If you encounter the behavior again, in addition to posting in the Skuid coummunity about the issue, I'd recommend posting to the Get Satisfaction community (https://getsatisfaction.com/getsatisfaction) directly and see if you get any traction that way.
Photo of Nepz Solutions

Nepz Solutions

  • 442 Points 250 badge 2x thumb
No Problem, Barry. Thanks a lot !