Possible bug with Date/Time condition using NOW

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I'm on 9.5.3 and am getting the following error:



Here is the code to reproduce:
<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" useviewportmeta="true" showheader="true">
    <models>
        <model id="Contact" limit="20" query="true" createrowifnonefound="false" datasource="salesforce" type="" sobject="Contact">
            <fields>
                <field id="CreatedDate"/>
            </fields>
            <conditions>
                <condition type="fieldvalue" value="NOW" enclosevalueinquotes="false" field="CreatedDate" operator="lt"/>
            </conditions>
            <actions/>
        </model>
    </models>
    <components/>
    <resources>
        <labels/>
        <javascript/>
        <css/>
    </resources>
    <styles>
        <styleitem type="background" bgtype="none"/>
    </styles>
</skuidpage>
Photo of Andrew N

Andrew N

  • 1,178 Points 1k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Official Response
The issue with NOW being sent in the SOQL queries has been resolved in Brooklyn Update 1, Iteration 5 which is now available from the Skuid Releases page at http://www.skuid.com/skuidreleases. As a reminder, Salesforce does not allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.