Portions of Overlay Fail to Appear, Require Refresh

  • 1
  • Question
  • Updated 7 months ago
  • Answered
Hi Skuid Support, 

My team has been complaining for about a week now that when they pull up our Salesforce Opportunity overlay, elements of the page fail to load, meaning whole tabs or portions of the page will be blank once loading is "complete". Oftentimes this can be corrected by reloading the page, but not always, and reloading is time-consuming because the overlay is quite large. 

If I had to guess, I'd say the size of the page is causing queries to fail, making it so the required fields do not render. Does that sound like it could be correct? 

What elements of an overlay tend to take up the most space, data-wise, and would thereby be the most beneficial to remove if possible? 

Below are three screenshots of field sets that failed to load. 


Photo of Eugene Rinehart

Eugene Rinehart

  • 592 Points 500 badge 2x thumb

Posted 7 months ago

  • 1
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,320 Points 5k badge 2x thumb
Eugene,

I'm not sure if the size of the page would cause queries to fail (I'd be more suspicious of the amount of data pulled in or models that have a lot of conditions / complicated conditions), but I do have an idea that might help with your page loading experience. Deferring model loads as long as possible (not querying the model on page load and only querying them once you need that info) may help you split up your model loads and let the sections of your page load. For instance, you may be able to defer loading of some of your models until a tab is clicked where that model is used. Then, in the tab actions (either when first shown or whenever selected, depending on if the data only needs to be loaded once or if it may be changed in other parts of the page), you can query the model(s). It will mean that your users may have to wait a second before the tab loads, but it will also make your initial page load quicker, and I think it might help with some of your sections just not loading at all. 

Thanks!
Amy
Photo of Eugene Rinehart

Eugene Rinehart

  • 592 Points 500 badge 2x thumb
Hi Amy! I'm happy to confirm that this issue was resolved with Skuid support. We recently started using a Page Include, and some of the Components on the included page shared a name with those on the parent page. This caused them to kind of crash into each other and fail. We resolved this by re-naming the Components on the included page, and our fields haven't disappeared since. 
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,320 Points 5k badge 2x thumb
Oh okay, good to hear! I'm glad we were able to help you get it sorted out :)