Platform REST API Access - No Proxy

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
I am trying to access a behind firewall (non-public) REST API using the Skuid platform.  We have the same API in the public cloud and private cloud for clients.  From my development machine, if I use the PROXY flag when setting up the datasource, it works fine and I can see the call in Fiddler go to SKUID proxy to hit the public instance API.  When I switch the Flag off or even create a new datasource without the PROXY flag, I never see a call actually emit from the client browser/machine to local endpoint setup. 

Has anyone been successful using a non-proxy setup with a private REST endpoint?  If so, what might I be missing?

Thanks in advance

Mike  
Photo of Mike Wolfel

Mike Wolfel

  • 100 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Hi Mike, your requests should be working with the PROXY flag turned off. Can you check your javascript console and see if you're getting any errors? Especially look for an error mentioning CORS or "Access-Control-Allow-Origin". Another thing to look at is if your endpoint is served over https. If it's just an http endpoint, your browser will reject that request for being a "mixed content request". If a page is served over https, all requests from that page must also be https.
Photo of Mike Wolfel

Mike Wolfel

  • 100 Points 100 badge 2x thumb
Ben, thanks!  That was the issue exactly, but I did not catch it at first for some reason.  Problem fixed.