Picklist Rendering and Record Types for New, Unsaved Rows

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
I've noticed that the standard field renderer for picklist values does not take record types into consideration for New, Unsaved Rows.

The two images below best describe my problem, and I was wondering how I could make sure that the drop-down for "Description" is correct when a new Row is created?


A new, unsaved Row shows All Picklist Values


After the Row is saved and edited, only then is the correct list shown.


The Conditions on the Table's Model specify that the Row must be of the 'MISC' type. But it seems that the picklist values are correct only once the Row has been saved, and consequently edited again.
Photo of mB Roman Melnik

mB Roman Melnik

  • 2,802 Points 2k badge 2x thumb

Posted 4 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
A regression was introduced in one of the recent versions of Skuid such that picklists were no longer looking to record type to filter available values.  This has been fixed in the 5.21 version that is now available on the skuidify.com/skuidreleases page. 
Photo of mB Roman Melnik

mB Roman Melnik

  • 2,802 Points 2k badge 2x thumb
Hi Rob,

Thanks for the prompt reply. I've upgraded to 5.21, but am still experiencing this issue for new, unsaved rows.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Does this happen for all users, or just certain users? Are you running this as an Admin?
Photo of mB Roman Melnik

mB Roman Melnik

  • 2,802 Points 2k badge 2x thumb
This happens for all users, including Admin.

I've included another screenshot to help illustrate that New,Unsaved Rows do not have the correct Picklist values.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
I'm guessing you have a Condition on your Model on the RecordTypeId field, where you're setting the Condition Value to be the RecordType's 15-digit Id, correct? If so, you'll need to change the Condition's Value one of the following:

(a) use the Record Type's API / Developer Name, e.g. "MISC", instead of the 15-digit Id. Skuid will translate the Developer Name into the 18-digit Id automatically behind the scenes. To find this, go to the Record Type's detail page, and find where it says "Record Type Name" (not Record Type Label).
(b) use the 18-digit Id.

We know this is lame, we're working on it. In the next release of skuid, you should be able to have a Condition on 15-digit and it should work fine, but right now, if you have the 15-digit, it won't work.
(Edited)
Photo of mB Roman Melnik

mB Roman Melnik

  • 2,802 Points 2k badge 2x thumb
Ah! That makes sense. I changed to the 18-digit Id and it works perfectly now. Thanks Zach.