Pickist rendering

  • 1
  • Problem
  • Updated 3 months ago
  • In Progress
When i use "Ride - Uber" in a picklist and use it to render a table, the table does not work.  If I change the picklist value to "Ride Uber" it works.  I used to be able to use "-"? 
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb

Posted 3 months ago

  • 1
Photo of Mike Dwyer

Mike Dwyer

  • 3,390 Points 3k badge 2x thumb
Suggest you copy the full string from the picklist to the rendering rule. The dashes may look alike but be from different character sets.
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
With the new version the rendering rule is also a pic list
Photo of Mike Dwyer

Mike Dwyer

  • 3,390 Points 3k badge 2x thumb
So the rendering rule shows Ride - Uber as a choice? Without an official response, I'm wondering a couple of things: Is the field included in your model? In prior versions, I think you could create a rule on a field even if it was not in the model; I could be wrong. If it is in the model, can you override the field metadata and re-enter the picklist values?

It might also be helpful for the engineers to know if the field is a standalone or a global picklist.
 
(Edited)
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
The field is included in the model.  It is a global value set.  
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
The field is included in the model.  It is a global value set.  
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
This is still an issue.  It also does not work as "mobile/fax" as a picklist value.