Page Include loading duplicate Components

  • 1
  • Problem
  • Updated 5 years ago
  • Solved
I'm trying to use a "Page Include" Component on a page, but keep getting my fields/components duplicated on this included page. (i.e. I get one set with the correct values I have in my record, and another set that is blank).

I've played around with changing the conditions on the included page, as well on the "page include" component ("advanced settings" tab).
Here are the settings I currently have in use:
For the Original Page:

And for the Page Include:



And, actually testing it now, I must have changed something -- since I'm only getting blank fields in my included page.

Anyone have advice? I have a feeling I'm missing something simple/fundamental...

Thanks!
Photo of Pat Hicks

Pat Hicks

  • 898 Points 500 badge 2x thumb
  • ready to pull my hair out.

Posted 5 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 48,984 Points 20k badge 2x thumb
First, try changing you Page Include query string to be ?id={{$Param.id}} (with the id after $Param being lower-case). This might resolve the "blank fields in my included page" scenario.

For your larger question, if you're seeing duplicate content, are you loading the same page in? That is, what is the name of the "parent" Skuid Page? 

Perhaps could you post a screenshot of your full Skuid Page layout, both in the Page Composer as well as in Preview, so we could get a sense of what all's going on?
Photo of Pat Hicks

Pat Hicks

  • 898 Points 500 badge 2x thumb
Wow, looks like changing "id" to being lowercase solved everything!
Not 100% sure what I had done earlier that put duplicate fields in there, but we're looking good now...

As far as parent page... Is that the one I'm including the page on? We've got an AuditUI page & a DataEntryUI page -- DataEntry is being included in a tab on the AuditUI.

Here's a shot from the Page Composer, just for reference. 


And the Preview Page:

I had been seeing each one of those field editors (eg: Group, Receive Date, Doc #, etc.) being duplicated above it (almost like multiple rows in a table).
But -- for whatever reason -- this is no longer happening & the record is shown here just right. Which I am totally OK with.

Thanks!

Photo of Pat Hicks

Pat Hicks

  • 898 Points 500 badge 2x thumb
Now the only thing I'm dealing with is some CSS formatting on separate tabs being affected after the page loads -- presumably because the Page Include loads new stylesheets?
(Edited)
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Yes - the included page brings everything with it into the parent page - and so you may have some CSS conflicts if you've overridden things on the included page.