Page re-direction issue

  • 1
  • Question
  • Updated 2 years ago
Hi,

Facing issue in re-directing to detail page after record creation. 

I am using wizard control (Step1, Step2, Step3) to create a record from skuid. After click on 'save' button which is in step 3, expecting the new record to open in detail page of the record (it's navigating to detail page but not showing record data except tabs which i used, here it's failing to get the id of the new record after navigating to detail page) record id is generating and creating record in  list view.

 Added few field's and button (buttons to navigate previous & next step) in each step but in step3 added one more button (Save and submit) to save the record, below are the actions behind save and submit button 

1. Show message and block UI
2. Update a field on rows
3.  Save Model Changes (given my model name)
4. Unblock the UI
5. Close all popups
5. Redirect to URL (URL : /apex/ui?page=My detail page name&Id={{{Id}}}&navOpen=Imperium)

Expectation: Record should navigate to detail page immediate after record creation.

Thanks
kailas suresh
Photo of Kailas

Kailas

  • 330 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Kailas,

How is your save and submit button created? Is it in a page title or a button created by the wizard? You may have to specify which model you are pulling the Id from by using global merge syntax. You'll do that by putting {{$Model.RecordModelName.data.0.Id}} instead of {{Id}}. RecordModelName will be the name of the model that the new record is created on.

Thanks!
Amy
Photo of Kailas

Kailas

  • 330 Points 250 badge 2x thumb
Hi Amy,

Thanks for the input,

My save and submit button is created on wizard and tried with {{$Model.RecordModelName.data.0.Id}} by changing my re direction URL but it didn't work as expected (navigating to detail page but not displaying record related information)

Below is the modified re direction URL as suggested:

/apex/skuid__ui?page=PaT_HRContact_Detail&Id={{$Model.HRContact_New.data.0.Id}}&navOpen=Imperium

Could you please provide some more inputs on this..
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Kailas,

Make sure that your Contact model that displays on the detail page has the correct condition setup to look at a page/url parameter for its id. The parameter in the condition is case sensitive, so it has to be the exact same as what you pass, in this case "Id". Here's a screenshot to illustrate:



Thanks!
Amy