Page pack mass action not working for child pages.

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
First noticed in 7.20.

Packing and unpacking a child page without it's master page in the same pagepack results in the unpacked child page being completely blank.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
The strange thing is that the XML looks right.... the XML of the unpacked page is identical to the XML of the source page.

But the connection to the master is somehow lost... even if the master exists in the org... So the page shows completely blank.

How can I fix this?

I don't want to pack and unpack the master page because there are slight modifications to it in the target org that I don't want to have to re-create.
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Matt,

We'll take a look at why the page got detached from the Master page, but the quickest way to get it reattached is to query for the record in the Salesforce Dev Console, and update the value manually. You could also build a Skuid page on the Page object, add the MasterPage__c field to the layout, and edit it that way, of course.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Always rather build a skuid page than enter the strange foreign world of the dev console!
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Of course! 
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
This is fixed as of Banzai Update 5 (7.21+). Thanks for reporting this, Matt!
(Edited)