Page Include on my Home Page

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have built a home page following the tutorial http://help.skuidify.com/m/supercharge-your-ui/l/117747-reclaim-the-salesforce-home-page. Everything is working perfectly - both when I view the page and when I navigate to the Home tab.

I then added a Page Inlude (Company Calendar) to the page; which I have used on other pages and workes perfect. When I "preview" it everything comes in perfect.
 
However, when I navigate to the home tab this is what I see: 

It doesn't show my calendar at all. I have messed around with the query string but nothing I try seems to be working. Any help would be greatly appreciated.
Photo of Megan Vaughan

Megan Vaughan

  • 872 Points 500 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Here is a guess. 

I'm thinking you have created a home page component that calls a VF page that in turn calls Skuid. 
In that VF page  - you have used the "skuid:page" component  (i.e. your VF code looks like something like this: 

  1. &lt;apex:page showHeader="<strong>true</strong>" sidebar="<strong>false</strong>" readonly="true" docType="html-5.0"<br>
  2. &nbsp; &nbsp; &nbsp; &nbsp; title=<strong>"New Credit Card Order</strong>" controller=<strong>"AuthorizeDotNetAPI</strong>"&gt;<br>
  3. &nbsp; &nbsp; &lt;skuid:page page="<strong>SubmitCreditCardOrder"</strong> /&gt;<br>
  4. &lt;/apex:page&gt;

If this is true,  you need to create a local copy of the Page include VisualForce page.   More information on doing that is here. 










Photo of Joe Ort

Joe Ort

  • 2,256 Points 2k badge 2x thumb
I was able to go through and get the page includes working based on that link. How do I do the following once the right page include shows up:
  • Revert to Modern theme (it's back to the default for some reason)
  • I have some things on the AF working to log activities and one of my pop ups doesn't have the save button on the pop up.  It shows up on one of my row actions but not a different one.  It worked fine before putting into a page include.