page assignments / licensing

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
I have just loaded in a package to a client's sandbox with Skuid Pages. The entire org won't be using Skuid at this time, so I am using VF override pages that should direct the appropriate user to the correct Contact Tab & View pages. I have created Page Assignments that give the appropriate profile access to those Skuid Tab & View override actions. Furthermore, I have ensured that the profile has the Skuid Page Viewer Permission Set.

I personally can see the SKUID pages, but I am System Admin and installed SKUID, so I'm sure I have all permissions necessary.

However, my users in that Profile aren't able to see the SKUID pages. They are just being directed to the standard Tab and View pages. Is there a permission setting that I am missing?

Here is the VF override page code that I am using:

 <apex:page standardController="Contact" recordSetVar="a" extensions="skuid.Redirects" action="{!redirect}?objectType=Contact&actionType=Tab">
</apex:page>


<apex:page standardController="Contact" action="{!redirect}&actionType=View&objectType=Contact" extensions="skuid.Redirects">
</apex:page>
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,270 Points 3k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,470 Points 10k badge 2x thumb
Have you checked to see if those users have been assigned Skuid licenses?
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,270 Points 3k badge 2x thumb
Hey Ben, yes under Profile --> App Permissions --> those user do have the Skuid License. I believe when I installed Skuid into the sandbox, I gave access to all Users.
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,470 Points 10k badge 2x thumb
What about 
Setup -> Installed Packages --> Skuid --> Manage Licenses ?
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,470 Points 10k badge 2x thumb
The only other thing I can think of would be the sharing settings on the skuid__Page__c object. What is the access level for the Page object in Setup --> Security Controls --> Sharing Settings
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,270 Points 3k badge 2x thumb
That was it...OWD for Page object was set to private. Thanks Ben!