Option: 'Configure edit mode popup ' to be in 'read with inline editing' mode instead

  • 1
  • Idea
  • Updated 2 years ago
  • Under Consideration
Hi,

I'm wondering if there's a way to make my table's field in the 'configure edit mode popup' to be in read with inline editing instead

I tried setting the table tot hat option or read only, and fields always appear in edit mode

Even when i check the box 'read only' in each field, same result.

I understand it's probably intended.

But is there any way to bypass that without use of field renderer?


Thank you
Photo of Dave

Dave

  • 5,538 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,210 Points 5k badge 2x thumb
Dave~

I am unable to reproduce this error. Do you have any CSS or JavaScript on the page that is possibly overriding your "read with inline edit" selection? What about in the theme you are using for this page? Or possibly in the master page? 

Thanks!
Karen
Photo of Dave

Dave

  • 5,538 Points 5k badge 2x thumb
Hi Karen,

No i have none of those,

And here a sample page i just created to show you what i'm talking about



<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true" tabtooverride="Account">   <models>
      <model id="Account" limit="1" query="true" createrowifnonefound="false" sobject="Account" adapter="" type="">
         <fields>
            <field id="Name"/>
            <field id="CreatedDate"/>
            <field id="Fax"/>
            <field id="Phone"/>
            <field id="Rating"/>
         </fields>
         <conditions>
            <condition type="param" enclosevalueinquotes="true" operator="=" field="Id" value="id"/>
         </conditions>
         <actions/>
      </model>
   </models>
   <components>
      <tfg__collapsiblewrapper title="New Wrapper" showheader="yes" collapsible="open" uniqueid="pageLoaderWrapper" cssclass="pageLoaderWrapper">
         <components/>
         <styles>
            <styleitem type="background"/>
            <styleitem type="border"/>
            <styleitem type="size"/>
         </styles>
         <onbeforefirstopenactions>
            <action type="blockUI" message="Loading..." timeout="1000"/>
         </onbeforefirstopenactions>
         <onafterfirstopenactions/>
         <onbeforeopenactions/>
         <onafteropenactions/>
         <onbeforecloseactions/>
         <onaftercloseactions/>
         <renderconditions logictype="and"/>
      </tfg__collapsiblewrapper>
      <pagetitle model="Account" uniqueid="sk-lx3g8-68">
         <maintitle>
            <template>{{Name}}</template>
         </maintitle>
         <subtitle>
            <template>{{Model.label}}</template>
         </subtitle>
         <actions>
            <action type="delete"/>
            <action type="clone"/>
            <action type="share"/>
            <action type="savecancel" window="self"/>
         </actions>
      </pagetitle>
      <basicfieldeditor showsavecancel="false" showheader="true" model="Account" mode="read" uniqueid="sk-lx3g8-69">
         <columns>
            <column width="100%">
               <sections>
                  <section title="Basics" collapsible="no">
                     <fields>
                        <field type="COMBO" valuehalign="" editmodebehavior="custompopup">
                           <label>Click here and popup will always be in edit mode, no matter what setting i set</label>
                           <template>
                              <contents/>
                           </template>
                           <editmodepopup title="Template Field" width="450">
                              <components>
                                 <basicfieldeditor showsavecancel="false" mode="read" model="Account" uniqueid="sk-2xGJ1E-125" buttonposition="">
                                    <columns>
                                       <column width="100%">
                                          <sections>
                                             <section title="">
                                                <fields>
                                                   <field id="Name" valuehalign="" type=""/>
                                                   <field id="Fax"/>
                                                   <field id="Phone"/>
                                                   <field id="Rating"/>
                                                </fields>
                                             </section>
                                          </sections>
                                       </column>
                                    </columns>
                                 </basicfieldeditor>
                              </components>
                           </editmodepopup>
                        </field>
                     </fields>
                  </section>
               </sections>
            </column>
         </columns>
      </basicfieldeditor>
   </components>
   <resources>
      <labels/>
      <css/>
      <javascript/>
   </resources>
   <styles>
      <styleitem type="background" bgtype="none"/>
   </styles>
</skuidpage>



Thx
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,210 Points 5k badge 2x thumb
Dave~

Have you looked in your component pack ("tfg" Component Pack)? What is a field type "COMBO" and what are its properties? Is there a reason you're using the popup within a template field? Is it possible to have the popup open via clicking on a button instead? 

Thanks!
Karen
Photo of Dave

Dave

  • 5,538 Points 5k badge 2x thumb
Sorry, the TFG component was just there for a previous test and nothing to do with issue I'm explaining. (you can remove it, it won't change anything)

The reason i'm using a template field, is I want to show my users, many different fields' data for them to choose from , to manually input the data in field i show in template

A button would be very confusing as will not blend with the rest of field editor.

Can this popup be show in 'read only mode' without a snippet? or it's made to be always on edit mode (the popup is clearly named: 'Edit mode popup', so may be intended)

Thx
(Edited)
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Karen - Field type "COMBO" is the field type of the stock Skuid template field.  The template field provides an "edit" option using either the default popup or a custom popup.  Dave is using all stock features here, nothing custom from what I can tell.

Dave - In looking in to this one, it looks like skuid is forcing the context of the popup to edit mode so all components on the popup will be built in edit mode regardless of their configured value (unfortunate in your case).  Also unfortunately, Skuid doesn't provide the ability to use a custom renderer on a template field (there's a post somewhere asking for this but I can't find it right now).  In short, there's no declarative way to accomplish what you are after, however you do have three options:

1) Add a TFG popup controller to the custom popup and use the OnOpen snippet option.  In the snippet, you'll want to look for your field editor (give it a unique id) and change it's mode to read.  You can use the article at https://community.skuid.com/skuid/topics/_edit_mode_button for guidance on how to accomplish.

2) Use a standard field (any field will do) and write a custom renderer that takes care of displaying a popup, etc.  You would use the create createPopupFromPopupXML api to accomplish this.

3) Submit an new idea to Skuid asking them for support of this use case :)

Hope this helps!
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,210 Points 5k badge 2x thumb
Hi!

Barry, thanks for your great ideas on how to help Dave with this!

Dave, hope one of the solutions Barry proposed works for you.

Like Barry suggested, I will also mark this an an idea for the team to consider for a future release. Community, vote it up if this is something you would also like to see!!! 

Thanks!
Karen