OAuth callback page URL path not set correctly when using Skuid page on Salesforce Public Site

  • 1
  • Problem
  • Updated 1 year ago
  • In Progress
We are running a Skuid page with an OAuth data source model on a Public Site with a secure domain such as https://mysitename.secure.force.com/mysiteprefix/apex/skuid__UI?page=Test. When the model starts to load the OAuth authentication flow starts by popping up a window with the URL https://mysitename.secure.force.com/apex/skuid__oauthcallback#oauth_redirect=https%253A%252F%252Facc...etc The popup windows is unable to load because the URL to the Skuid oauthcallback page does not contain the right prefix to launch the Skuid oauthcallback VF page from a public site. It should be https://mysitename.secure.force.com/mysiteprefix/skuid__oauthcallback#oauth_redirect=https%253A%252F...etc. because Apex pages from public sites need to be accessed from the prefix.

Everything works fine when the same page is used from the standard Salesforce domain it only fails when using a site.

Can we configure or change the prefix when initiating this OAuth flow? Note that we have not reached the oauth consent/grant screen and the actual callback redirect has not yet happened although the remaining query parameters like the redirect_uri in the skuid__oauthcallback URL also have the wrong prefix.
Photo of Stephen Chan

Stephen Chan

  • 956 Points 500 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Khamla Phimmachack

Khamla Phimmachack, Official Rep

  • 1,536 Points 1k badge 2x thumb
Hi Stephen,

This issue may have been related to a bug that has now been resolved in the Brooklyn Update 1 - Iteration 2 and Brooklyn - Iteration 6 releases which are now available from the Skuid Releases page

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.

Thanks!
Photo of Stephen Chan

Stephen Chan

  • 956 Points 500 badge 2x thumb
Thanks for the response, I've just now upgraded to Skuid 10.0.2 and retested this and I'm afraid the issue still exists. The OAuth redirect URLs still miss the Salesforce public site (and probably communities as well) prefix so I cannot use Skuid OAuth to authenticate in a Salesforce site or community. I did review the various release notes and found no mention of a fix related to this issue.

Cheers,
Stephen
Photo of Khamla Phimmachack

Khamla Phimmachack, Official Rep

  • 1,536 Points 1k badge 2x thumb
Hi Stephen,

We are still looking into this problem and trying to reproduce it on our end. Once we confirm the problem, we will provide an update. Thanks!