Not able to connect MySQL hosted in AWS to skuid

  • 1
  • Problem
  • Updated 2 weeks ago
  • Acknowledged
I have created a MySql database in Amazon RDS. While trying to create a Data source configuration in Skuid, I am getting the following error - 

Unsuccessful.

Skuid could not connect to the Data Source.
Please check all configuration values and make sure the Data Source can be accessed from Skuid's web servers in your region.

error

I have already white listed the Skuid IP addresses in security group.
Photo of Ankur Jain

Ankur Jain

  • 120 Points 100 badge 2x thumb

Posted 4 weeks ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Do you have SSL enabled on the Data Source?
Photo of Ankur Jain

Ankur Jain

  • 120 Points 100 badge 2x thumb
I have granted SSL access to the database user, but Unfortunately since my Developer account has expired, I can not verify this :-(

There is no specific setting other than granting user SSL on the Mysql RDS instance in AWS.

GRANT SELECT ON mydatabase.* TO 'myuser'@'%' IDENTIFIED BY '....' REQUIRE SSL;

Once my developer environment is extended, I will go into the system and verify the same.


Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
I've extended your trial. 

For your RDS AWS configuration, make sure that you've made the database publicly-accessible.

Also, maybe check the RDS logs to see if there are any errors there related to network connectivity.
And also click "Test Connection" in the Skuid Data Source configuration page, and check the Network Requests in Chrome's Network Console, there may be some information in the "Response" to the network request to /ping that might be helpful.
Photo of Ankur Jain

Ankur Jain

  • 120 Points 100 badge 2x thumb
Thanks for the extension, 
Using the Grant command worked, 

But skuid is not able to import any Data Source objects, neither it is able to create a Data Source Object when I am using the option Manually create a Data Source Object.

It is giving me the attached error. "Test Connection" is working successfully.

Thanks in advance for your help.

Regards,
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
There is currently a known issue with "Manually create Data Source Object" --- we are working to address this.

You should be able to "Import Data Source Objects" though --- try only importing Data Source Objects from one schema at a time.
Photo of Ankur Jain

Ankur Jain

  • 120 Points 100 badge 2x thumb
Hi Zach,

I have a table in my schema, but the skuid interface does not show the table when I click on Import Data Source Objects.

In the screenshot, as you can see the table in the schema is visible in mysql workbench.
On the right, when I click Import Data Source objects, first it shows a popup, but when it shows the window - there are no tables visible.

When I am inspecting the skuid page on the network tab against "source-entity"  Response is "null"

I am wondering, if the table created needs to be of any specific encoding type ?
Currently the Table collation - latin1_swedish_ci

Thanks for your help in debugging this issue.


Regards,
Photo of Ankur Jain

Ankur Jain

  • 120 Points 100 badge 2x thumb
@Zach

Any luck in figuring out the issue ?

Regards,
Ankur