Newly installed skuid unable to load 'skuidcore' Component Pack

  • 1
  • Problem
  • Updated 1 month ago
  • Solved
Hi,

We are setting up a trialforce org to use and installed skuid, however when I try to load any of the tabs related to Skuid (pages, theme etc), all that loads is this screen below and I get an error saying:

An error occurred while attempting to load the "skuidcore" Component Pack. There may be an issue with the name or location of your Component Pack manifest files. Error: Unable to retrieve content of file

This is the second time we have had this issue, both times was when we just installed skuid onto a fresh new instance.



Thank you,

Emma
Photo of Emma

Emma

  • 386 Points 250 badge 2x thumb
  • confused and frustrated.

Posted 3 months ago

  • 1
Photo of David Forder

David Forder

  • 2,380 Points 2k badge 2x thumb
Emma and the rest of us are still having this issue. Cannot load any pages or page list at all in this org. Any assistance would be great.

Just reinstalled skuid but still it wont load
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Edited:
Hi Emma and David,

Thank you for reaching out, I'm sorry to hear that you are running into this issue.
Which version did you install? I couldn't find a general issue with the latest installer (12.0.4).
Probably no need to open a Salesforce Support ticket.
(Edited)
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Hi Emma and David, I'm sorry I misunderstood a detail of the issue. Could you please double check if your Salesforce users have the Skuid Permission Sets? Please see here:
https://docs.skuid.com/latest/en/skuid/deploy/salesforce/user-access/
Photo of Emma

Emma

  • 386 Points 250 badge 2x thumb
Hi Luzie, 

We did check that the users had the skuid permission sets, and as admin David had the skuid admin permission set and still received this error.

Without us changing anything, it has begun to work again randomly, just like the previous installs we had that gave this error. This is going to be a problem if when we need to install skuid it takes an indeterminate about of time to actually work...

We have Millau (11.2.16) version installed.

Thank you
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Hi Emma, thank you for the feedback, good to hear that it works now. One more thing that you can check: your and David's "Pages" and "Page Assignments" object permissions. Independent of the Skuid Permission Sets, you can change those object permissions in the Salesforce Setup. If the permissions are setup correctly but the error remains, you could open a Salesforce Support case. It could be an org specific problem. 

In order to try to reproduce it, I would do the following:
  1. install the latest Skuid version in new sandbox: https://www.skuid.com/releases/salesforce/
  2. assign the Skuid permission sets
  3. check the "Pages" and "Page Assignments" object permissions
  4. see if you can reproduce the issue
Below information is from https://docs.skuid.com/latest/en/skuid/deploy/salesforce/user-access/

Any user who will be viewing Skuid needs to be assigned a Skuid license and the Skuid Page Viewer permission set. Any user who will be editing Skuid Pages needs to be assigned the Skuid Page Builder Permission set.

Like any other Salesforce Custom Objects, you can configure security, sharing and permissions for the Skuid Page and Page Assignment objects. We recommend you configure the sharing setting for these objects to public read only.
  • The Skuid Page Viewer permission set lets users read Pages and Page Assignments.
  • The Skuid Page Builder permission set lets users read, create, edit and delete Pages, Page Assignments, Page Versions, and other objects in the Skuid package.
  • The Skuid Admin permission set gives users the same options as the Skuid Page Builder permission set, and also allows access the XML Editor on Skuid pages.
  • Out of the box, none of these permission sets have View All and Modify All permissions on these objects.
Photo of Emma

Emma

  • 386 Points 250 badge 2x thumb
We will give this a go to try and reproduce the issue.

We are still having some other issues with skuid on our new instance unfortunately. I'm not sure if they're related or not.

When we try to unpack a page pack or pages from a module, the popup message saying it is refreshing the static resource comes up and then it just freezes, no matter how long we leave it loading. It seems to still unpack some of the pages if we wait long enough, but it never comes up saying done or anything beyond the first message.

On top of that, there is an issue with the page lists. It isn't loading all the pages that are there in the list view. We have it set to sort alphabetically, and the first page loads. When we click load more, it jumps from a page starting with E to a page starting with P, when there should be 25 pages in between those two pages. If we type in one of the page names that is missing from the list view, it appears then in the results.

I would appreciate it if you have any ideas or suggestions on what to do to fix this.

Thank you in advance!
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Emma, sorry for the late response, the issue that you described (not loading all the pages) is under investigation by our development team at the moment. I will update you as soon as I know more. Thanks, Luzie
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
The issue with name "Records not being included in model when loading more records" has been resolved in 12.0.6 which is now available from the Skuid Releases page at https://www.skuid.com/releases/salesforce. As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes after you upgraded.
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Thanks Emma. Are you referring to this post: https://community.skuid.com/skuid/topics/issue-with-unpacking-pages-in-skuid-version-11-2-16-and-11-... ?

Can you confirm you still use Skuid version 11.2.16 ?
Photo of Emma

Emma

  • 386 Points 250 badge 2x thumb
That post and we have a couple environments with the same problem. They were on 11.2.16 but we have since updated them to version 11.2.18. This fixed the issue of "Records not being included in model when loading more records" but not the unpacking issue.

We have another environment 11.2.11 and another on 11.2.12 and these don't have any issue with page packs
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Thank you for the detailed information, Emma. This has been logged as a known issue in our tracking system and our dev team is working on it. They could identify the root cause of the issue and the fix will be delivered soon.
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Hi Emma, the page pack issue fix was addressed in CORE-2276, which is part of 11.2.19 which is now available from the Skuid Releases page at https://www.skuid.com/releases/salesforce. As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes after you upgraded.
Photo of Emma

Emma

  • 386 Points 250 badge 2x thumb
Hi Luzie, thanks for the update and the fix! We updated one of the orgs with the issue and it has fixed it so I will roll out the update to the other instances with the issue.