New Profile is not recognizing UI_Fields

  • 1
  • Problem
  • Updated 3 years ago
I have created UI-Fields on an object.  I have set up a new profile and given the object Read, Create, Edit capability.  I have checked "Load Model data on page load" and "Max # of records (Limit)" to 1.  I have set default values on the picklist.  When I load the data in a field editor I see the data from the record.  However, the picklist values are blank.  Is there a permission that I am missing?  It seems that field rendering is not working.
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Hello Bill -

When you indicate you've created UI-Only fields on an object, do you mean you've created UI-Only fields on a Skuid Model?  

If so and if you're viewing an existing record, then the behavior you are encountering is by design unfortunately.  In short, skuid applies default values to new records only (which is similar to the way standard salesforce behaves).  Therefore, regardless of what you specified as a default value in the UI-Only field in the skuid model, when viewing an existing record, all UI-Only fields will be blank initially.  You can read more about this at https://community.skuid.com/skuid/topics/checkbox-ui-only-field-with-default-true-showing-as-false-b....

One other note along these lines is that Skuid does not enforce any security on UI-Only fields outside of standard object access security.  In other words, if a user has access to the record, they will have access to all UI-Only fields.  Currently, there is no way to secure these fields unfortunately.

If I've misunderstand your scenario, let me know and we can dig further.
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
With a profile of "System Administrator" this screen is reading the UI-fields and has been since I started using UI-fields.

Here is what it is looks like in a custom profile:
  
The "save changes"  and "Cancel changes" should not show because the UI-field is blank;

Must have a setting in the custom profile not set? 
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Hi Bill -

This behavior leads me to believe that an error might be occuring somewhere, possibly in the UI-Fields.  Questions:

1) Do any of the UI-Only fields contain formulas?
2) Can you try changing the "If no rows in model" to "Ignore and don't render" and see if the buttons hide as expected?
3) Are the Title, Bricks, Edutation Type & Continuing Education Credits coming from the same EEEdit model?
4) What version of Skuid are you using?

Thanks!
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
No formulas
Changing the "Ignore and don't render" does not work
Yes, coming from same model
Banzai - Update 8 7.36
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Can you check the developer console and see if there are any errors/messages in there?
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
No errors in dev console.
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Unfortunately, I'm out of ideas at this point Bill, sorry.  There could be an error occurring that is getting "caught" and therefore not displayed or it could be something related to configuration.  Without being able to reproduce and/or see more details, I'm going to have to turn the baton over to the Skuid team to see if they can shed some light.

Skuid team?
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
Not sure why, but it started working this AM.
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Hey Bill - That is very strange.  Did your org get updated to Summer '16?
Photo of Bill Fox

Bill Fox

  • 7,934 Points 5k badge 2x thumb
Nope
Photo of Barry Schnell

Barry Schnell, Champion

  • 18,076 Points 10k badge 2x thumb
Very odd.  I would have expected it to work initially, but when it didn't and now it does, I can only imagine that something changed at some level.