Nested queue stops working

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Hi,

I have a page with two queues and a detail page. When I make my first selection on the outer queue, everything works correctly with no problems. However once I make a second selection on the outer queue, the nested queue refreshes/updates correctly but stops working. Clicking on any item in the nested queue fails to update the page include component - not even the UI block "Loading" happens any more.

Perhaps related, I see this warning in the console after the first time I click on the outer queue:
"Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. "

Any ideas on why this might be happening and how to fix it?

Thanks,
Kartik
Photo of Kartik Sethuraman

Kartik Sethuraman

  • 798 Points 500 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Did this work at one point and now no longer works?  
Have you upgraded to the most recent version of skuid?   (Go to skuidify.com/skuidreleases )   What version are you on? 
Photo of Kartik Sethuraman

Kartik Sethuraman

  • 798 Points 500 badge 2x thumb
Thanks for the quick reply Rob.

I'm using the latest summer 14 release. Here's what happens.

1. I click an option on the outer queue, inner queue populates correctly
2. I click an option on the inner queue, detail page populates correctly
3. I click a new option on the outer queue, inner queue populates correctly
4. I click an option on the inner queue, but the detail page does not reload. Don't even get a "Loading" UI block overlay message.


Thanks,
Kartik
(Edited)
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Kartik - there was a bug reported when the Summer release was first made available for testing (5.1)  that sounds very much like what you are experiencing.  Please make sure you are at least on 5.6 or 5.7.  Then if the bug continues we will need to dig into it.  Maybe grant us login rights and send a message to help@skuidify.com with your Org ID. 

Thanks. 
Photo of Kartik Sethuraman

Kartik Sethuraman

  • 798 Points 500 badge 2x thumb
Hi Rob,

We have version 5.6 installed currently. I've attempted to create a new page with nested queues and still encountered this issue. I've also tested the page in IE and Firefox, and it behaves the same in both browsers.

Thanks,
Kartik
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Thanks Kartik - we've been able to reproduce the bug on our end.  Our devs are looking at the root cause.  We'll be back in touch. 
Photo of Kartik Sethuraman

Kartik Sethuraman

  • 798 Points 500 badge 2x thumb
Great. I was able to implement our page a different way, but would certainly like to use nested queues in the future so keep me posted.

Thanks for the help Rob!
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
We have fixed this in dev, and it will be available as part of our next release. Our next release will be available by the end of the week.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
This has been fixed as of the latest version of Skuid, which was pushed to all Production orgs as of August 29. Also this version is now available on the AppExchange or from the Skuid Releases page.