Multiselect Filter dont remember last filter items

  • 1
  • Problem
  • Updated 3 years ago
Hi, I am trying to use multiselect filter against my model. I have configured it to remember my last filter. But  the problem is  it cannot remember my last filter. Its not happening all the time but intermittently . Most  cases if I have 1 or 2 item selected , it remembers. but if it has  few more, it acts wired. Any idea?
Photo of Tanzir Riad

Tanzir Riad

  • 414 Points 250 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
What version of Skuid are you on?  If you are on Banzai, you should be using the Server Side personalization option. This is set on the page settings (click page title at the top of the builder preview area).  This is our reccomended way of handling memory for multipicklist fields. 

Photo of Tanzir Riad

Tanzir Riad

  • 414 Points 250 badge 2x thumb
Hi Rob,
I am using Server side Personalization Mode. Wondering what I am missing. For an example: if I select items 1,2,3,4 and comeback later, it does select all four. But if now I deselect 2 and 4 and comeback again I can see all four selected. And it happens all the time except the first time. Not my exact selection.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Tanzir, 

I can reproduce the strange behavior your are reporting on Multi Select filters when using server side personalization.  It does look like when entries from the middle of a selection are removed,  this action is not remembered.  We will dig into this further and let you know what we find.