Multiple Sliding panels with page includes: Only first one works

  • 1
  • Problem
  • Updated 2 months ago
  • In Progress
Still having problems with sliding panels. I want to convert from popups to sliders in a lot of spots, but keep running into issues (or maybe the same issue). I have a page the has several button components in a deck component.  For of the buttons are to open sliders and display various page includes. I programmed the first button and it worked like magic. I was excited. I then programmed the other three. None of them work. I have set the buttons in the button components exactly the same, but on the first button that I added a slider to works. All buttons work fine if I switch back to popups. 
Windows 10 Pro
Latest Windows Chrome Browser
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 18,336 Points 10k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 18,336 Points 10k badge 2x thumb
I should add that the buttons launching these sliding panels is inside of a Deck Component
Photo of Stephen Sells

Stephen Sells, Alum

  • 17,326 Points 10k badge 2x thumb
Can you share the XML of your setup that isn't working?
Photo of Mark L

Mark L

  • 1,146 Points 1k badge 2x thumb
My guess is that models are conflicting between page includes.

It seems that if you use page includes, model names conflict with each other between pages. I've gotten in t he habit of prepending all my models with my page name as such: PageName__ModelName to prevent conflicts when using page includes.
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 18,336 Points 10k badge 2x thumb
Thanks mark. These issues aren’t a problem in the latest version of Skuid. I’m all set.