Multi Picklist not showing selections

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I recently updated to the newest version and now all of my multi select picklist fields show "1 selected" , "2 selected", "none selected" rather than listing each of the selections. How so I change it to show the way it did before?
Photo of Allison

Allison

  • 1,158 Points 1k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Richard Amantia II

Richard Amantia II

  • 754 Points 500 badge 2x thumb
Depending on page layout and the amount of space you have to work with, you could consider rendering the multi-select as a checkbox instead and allow users to see their selections that way. 

Not a true solution, but a work around for now.

Hope this helps.

Rich
Photo of Allison

Allison

  • 1,158 Points 1k badge 2x thumb

Thanks Rich.  I have a ton of these so it would be a bunch of work.  Is that the only way people have found to work around this "upgrade"?

Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Allison,

What Skuid version were you on before and what version are you on now? Are you seeing this behavior only when your fields are in edit mode or all the time?
Photo of Allison

Allison

  • 1,158 Points 1k badge 2x thumb
I'm not sure what I was on before we had updated to Brooklyn.  We are on 9.5.3 now.  The fields show properly when in Read mode but not in Edit mode (which is what we need).
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Allison,

It turns out this is now something you can adjust in the builder; you can set a limit, and over that limit the field will show the number of fields selected instead of the fields themselves (the default limit is 3, meaning you'll only see names of selected fields if you have 3 or less selected).
Look here in the page composer: