Moving Skuid Page to a Lightning Component

  • 1
  • Question
  • Updated 12 months ago
  • Answered
When trying to convert an Account Skuid Page to a Lightning Component, we're running into the issue of nothing showing up after we click save and preview. 

We have filled out:

Page Name: exact wording for the page name we're trying to call in Skuid

Page Type: Desktop

Id: Page ID of the Skuid Page we're trying to call

Page Parameters: We've left this blank. Should we be filling it out?

Filters: Blank - should we fill these out?

Thanks!
Photo of Jamie Crawford

Jamie Crawford

  • 486 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
You can leave everything blank except for Page Name. Page Name is the only one you need to fill out.
Photo of Jamie Crawford

Jamie Crawford

  • 486 Points 250 badge 2x thumb
I tried that and it still does not pull in anything. 

Any other suggestions?
Photo of Jamie Crawford

Jamie Crawford

  • 486 Points 250 badge 2x thumb
Also to add more context, we've launched it to all users AND saved and clicked preview, and it's still showing up blank. 
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
Did you generate a Support File via the 'More Page Actions' dropdown on the Skuid page? If you have any javascript in snippets etc. that haven't been moved to a Support File it can cause the page to showup blank.
Photo of Jamie Crawford

Jamie Crawford

  • 486 Points 250 badge 2x thumb
I've done that - now only half of the page include is showing up. The other is showing blank. Any idea why only half would load?

Thanks!
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
What's the content in that part of the page, our of interest? Is it a google map or anything like that? It might be fall afoul of Salesforce's security policies. Do you have any external javascript resources? I'm guessing it all works when you hit preview.
Photo of Jamie Crawford

Jamie Crawford

  • 486 Points 250 badge 2x thumb
No googlemap - just a panel set with a few field editors in it (nothing that would warrant a security issue). 

It's also blank in the preview. I generated a support file for the page, which worked on the other pages, but it didn't solve the issue. 
Photo of Gary Bailey

Gary Bailey

  • 1,628 Points 1k badge 2x thumb
Quick Question:  when you type the name of the Skuid Page into the field in the Lightning Component, does it search the name of available Skuid pages?  I'm having the same issue and I feel like yesterday when everything was working, that field searched available Skuid page names.  

Perhaps this is a symptom of the real problem.
Photo of Jamie Crawford

Jamie Crawford

  • 486 Points 250 badge 2x thumb
Hi Gary, 

No, it's never searched the name of the skuid page - I've always just manually typed it in letter for letter. 

It works fine for Accounts and Opportunities but we're just having issues with Contacts and Leads.
Photo of Gary Bailey

Gary Bailey

  • 1,628 Points 1k badge 2x thumb
I just upgraded to the latest release and now this issue has gone away.
Photo of Jamie Crawford

Jamie Crawford

  • 486 Points 250 badge 2x thumb
The latest release being Millau? We also upgraded to that.