Model Query Drops Info on Tab Switch

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
I have one particular custom object that I access through a tab on my accounts page. When I first go to an account page or refresh the browser, the table in this tab is complete and shows all custom object data for that account.

If I then click on the Activities tab (which has it's own related object) and then come back to the Timeline tab for this custom object, the table shows only a few (or sometimes none or in this particular case one) of the entries.

I've tried making it so that clicking on the Timeline tab goes through an action sequence that query's the model but that doesn't change the behavior. All other related objects on this page don't have this problem - they always show all records in their related tables ... and going to the tab of any other related object (WHPlans - a custom object or Opportunities or Cases) does not affect what the table in the Timelines tab shows.
Any ideas what's going on with this?
Photo of jdbuerger

jdbuerger

  • 502 Points 500 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
This is a long shot, but maybe you have an model action on the activities model that activates a condition on the Timeline model and you have the activities tab set to lazy load. Clicking on the Acticities tab may then be activating the condition on the timeline model.
Photo of jdbuerger

jdbuerger

  • 502 Points 500 badge 2x thumb
Close. On the Activities tab I have a calendar subtab which shows Calendar Events and Timelines. When I click on the Activities tab (even if the Tasks subtab is only viewed), the calendar locks in the timeline data for the date range shown on the calendar (because both the calendar and the Timelines list use the same model). I can fix that by using two separate models for Timelines.
(Edited)