Model Condition Help

  • 1
  • Problem
  • Updated 6 months ago
  • In Progress
Hello everyone,

We're having a bit of a problem with a model query. Here's the model:

<model id="IntakeQueues" limit="200" query="true" createrowifnonefound="false" datasource="salesforce" type="" sobject="Intake_Queue__c" doclone="" label="" labelplural="" orderby="CreatedDate DESC">
            <fields>
                <field id="RecordTypeId"/>
                <field id="Name"/>
                <field id="Full_Name__c"/>
                <field id="CreatedDate"/>
                <field id="Email_Address__c"/>
                <field id="IP__c"/>
                <field id="LDC__c"/>
                <field id="LDC__r.Name"/>
                <field id="Commodity__c"/>
                <field id="Commodity__r.Name"/>
            </fields>
            <conditions logic="(1 OR 2) AND 3 AND (4 OR 5)">
                <condition type="modelmerge" value="" field="IP__c" operator="=" model="WebSessionDetail" enclosevalueinquotes="true" mergefield="IP__c" novaluebehavior="noquery" state="" inactive="false"/>
                <condition type="modelmerge" value="" field="Email_Address__c" operator="=" model="WebSessionDetail" enclosevalueinquotes="true" mergefield="Email__c" novaluebehavior="noquery" state="" inactive="false"/>
                <condition type="modelmerge" value="" field="CreatedDate" operator="gt" model="WebSessionDetail" enclosevalueinquotes="false" mergefield="CreatedDate" novaluebehavior="noquery"/>
                <condition type="blank" value="null" field="Last_Name__c" state="" operator="!=" enclosevalueinquotes="false"/>
                <condition type="modelmerge" value="" field="Last_Name__c" operator="in" model="WebSessionDetail" enclosevalueinquotes="true" mergefield="Last_Name__c" novaluebehavior="deactivate"/>
            </conditions>
            <actions/>
        </model>
The problem that we're having is is with the (4 OR 5) portion. The model never populates with anything, unless we remove the 5th condition. It seems that (4 OR 5) should evaluate to true, so long as the field is not null. The model won't populate, even if the Last_Name__c field is not blank.

Thanks for any help.
Photo of John Freese

John Freese

  • 542 Points 500 badge 2x thumb

Posted 6 months ago

  • 1
Photo of Mike Dwyer

Mike Dwyer

  • 3,390 Points 3k badge 2x thumb
Just a quick thought on a Friday afternoon: For the "value" in the 5th condition, use {{Blank}}.