model based template not updating on query

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Pat,

Checking the 'do not run on each row' box doesn't actually do what you would expect. Instead of running the merge syntax in a row context for just the first row, it processes the merge syntax in a model context.

As a workaround, you can uncheck the box and use global merge syntax to get just the row you want.
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
All I had to do was uncheck the 'do not run on each row' and it worked. The context merge syntax should work in either situation imho.