List index out of bounds: 1

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Getting "List index out of bounds: 1" error when attempting to use the "Update a field on row(s)" action to update the value of a date/time field to NOW.
Photo of Adam Johnson

Adam Johnson

  • 1,000 Points 1k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Hi Adam,

Does your page have any metadata overrides on the date/time field? In other words, is the field a Date field that's being treated on your Skuid page like a date/time field, or vice versa? Or could there be any permissions settings protecting the field from being modified?
Photo of Adam Johnson

Adam Johnson

  • 1,000 Points 1k badge 2x thumb
You are on the right track. I didn't have the field in my model, so that is what was protecting it from being updated. :) I had previously been updating it via a snippet which didn't require the field to be in the model and didn't even think to add it before switching to an action to update. 

Thank you!