Links for upgrading to the latest Skuid package

  • 4
  • Problem
  • Updated 3 years ago
  • Acknowledged
One of my orgs has an outdated version of the Skuid managed package. I found Skuid on the appexchange, and it took me through (way too many) pages asking for names and logins, After finally choosing to install in a production system, I was redirected to this page: https://sites.secure.force.com/partne... . I'm not sure what to do here, though. Why am I on a partnerforce page? This won't install Skuid in my client's production org, will it? In any case, I do happen to have a partnerforce login, but when I used it the next page simply said I don't have the correct permissions to get to the next step. I suspect something is wrong here?

So, to get around this, I had to do some serious hunting around to find your page with the latest package install links. Finally found it here: http://www.skuidify.com/skuidreleases . Please make a link to this more prominent or publicly findable.
Photo of Peter Bender

Peter Bender, Champion

  • 6,296 Points 5k badge 2x thumb

Posted 6 years ago

  • 4
Photo of Josh Cutler

Josh Cutler, Official Rep

  • 874 Points 500 badge 2x thumb
Peter,

Thanks for your thoughtful input. I agree that navigating to the Skuid release page could be an easier process. I'll post back on this page when we have implemented a simpler and more "discoverable" way to access the Skuid package releases.

As you identified, the link (http://www.skuidify.com/skuidreleases) is the most direct path to major relases, nightly builds, and patchs.

Eddy,

I think we'll spin up a tutorial soon that answers your questions. Until then, here's your answer:

you only need to install the latest package release!

For example, the latest release version (at the time I write this) is 4.15.18 and is labeled "Patch of 4.15". Even though, it says "patch", the package contains the full version of Skuid. You do not need to install the latest major release before installing the patch. The patch contains all the code you will need.

-Josh
(Edited)