Lightning builder bug in Chrome - property input not showing if component is further down page

  • 1
  • Problem
  • Updated 4 months ago
  • Solved
In Lightning and in Chrome (I've tried deleting cookies/storage) when I click on some components in the Skuid builder (e.g. field on a table) and I have had to scroll down the page to click on that component, the inputs are hidden in the property editor (see screenshot). If I scroll back up the page they pop back in again.



Cheers!

Louis
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb

Posted 6 months ago

  • 1
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
Hello! I thought I'd provide a video explaining this issue better. I've found a possible fix too via applying a higher z-index to the inputs

Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,330 Points 1k badge 2x thumb
Hi Louis, thank you for the screenshot and the video. Could you please also let us know which version of Skuid is currently installed?
Here is my favourite way to check it quickly: while you are on any Skuid page, open the console and type skuid.version and hit enter :-)

We will investigate in this and reply shortly.

Thanks,
Luzie
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
Hey Luzie! We're on 11.1.13 but the issue also occurred in 11.1.11. I'm working in the Lightning Experience. Interestingly this bug doesn't affect the Skuid page when working in Classic.

Cheers!

Louis
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
Here's another example of it:

Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,330 Points 1k badge 2x thumb
Thank you for the details Louis, I could reproduce the issue of the disappearing fields in Chrome with Lightning and provided all information to our dev team.
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,330 Points 1k badge 2x thumb
Hi Louis,

You've probably already seen it, but I would like to update this community post with the information that the issue has been fixed since version 11.1.15.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.
 
Thanks again for alerting us of these issues!
Luzie
Photo of Louis Skelton

Louis Skelton

  • 4,878 Points 4k badge 2x thumb
Ooooh! Nice - thank you :)