lightning based themes are broken

  • 2
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
We built several custom themes based on Lightning. At some point, I believe with the Salesforce Sprint '17 update, all of those themes switched to looking like they were based on Modern. Can't figure out how to fix. Some of the themes looked right in our Sandbox which was running Brooklyn, while Production wasn't running Brooklyn. When we upgraded Production to Brooklyn, the themes didn't get fixed. I do have Update Out of Date Themes showing, but it just runs and runs, I've tried leaving it for 15 minutes and it never completes. I can have the theme looking right in Sandbox, and create a new theme in Production with the same files, and it looks to be based on Modern instead of Lightning. 
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb

Posted 2 years ago

  • 2
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Hello Jack,

I cannot say I've heard about others having this issue. It strikes me as odd that the Update Out of Date Themes isn't completing it's work. It hasn't taken over 30 seconds for me. 

What browser are you using? 
Could you provide any pictures with what you're seeing?

Thanks!
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
Well as of this morning, Sandbox is also showing what looks like a base of modern theme. I did Update out of Date Themes last Friday and I guess that's what did it. 

First image is how it is supposed to look, how it looked last week. Second image is how it looks now. 





This has happened to three themes that are in use in Production.
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
I think i'm experiencing the same issue, did you ever find a resolution for this? My lightning themes are showing that same exact blue theme intermittently. 
Photo of Jack Sanford

Jack Sanford, Champion

  • 8,322 Points 5k badge 2x thumb
Erik - I never actually resolved this, I ended up just using the standard Lightning Design theme and then using page-level CSS to adjust styling as needed. 
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb
In terms of the blue theme showing up intermittently, the resolution I found was that one of my other skuid components used within the lightning page had a theme specified so changing all my pages to "Default" fixed this.

 It's worth noting this behavior did not appear in Classic. Also worth noting that the "Update Out of Date Themes" button still runs indefinitely for me still (even after latest patch).