Lightning Application with skuid:page component

  • 2
  • Question
  • Updated 3 years ago
  • Answered
  • (Edited)
I'm trying to create a super simple application that uses the skuid:page component. My markup looks like this:
<aura:application >
    <skuid:page page="PricingPortalLite_Home"/>
</aura:application>
The problem is that when I preview the application ('/c/PricingPortalLite.app') I am getting a super unhelpful "Internal Server Error"...
Error message: An internal server error has occurred
Error ID: 810024311-2130 (164604962)
Any ideas?
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb

Posted 3 years ago

  • 2
Photo of Zach McElrath

Zach McElrath, Employee

  • 50,272 Points 50k badge 2x thumb
Start from ground zero -- try creating a blank Skuid Page from scratch, with no components in it, and save that, then use that in your Lightning App. Does that work, or does that still throw the server error?
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Yup I just made a completely blank new Desktop page and I got the following : 
Error message: An internal server error has occurred
Error ID: 1194030691-1943 (164604962)
At least the error ID number changed...
Photo of Zach McElrath

Zach McElrath, Employee

  • 50,272 Points 50k badge 2x thumb
Do you have My Domain enabled in your org?
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Yes I do.
Photo of Zach McElrath

Zach McElrath, Employee

  • 50,232 Points 50k badge 2x thumb
Wonderful! I have no further ideas :)

I would log a case with Salesforce Support. Give them the exact error number, grant login access and all that, and give them exact steps to replicate.

What Skuid version are you on?

Can you use any other simple Lightning Components, or components from any other managed package? e.g. the Stopwatch app's component?
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Actually it looks like the skuid pagebuilder isn't loading either... I made a bunch of lightning stuff before My Domain was enabled, and now that I've enabled it today it seems like I can see components they just all have Internal Server Errors. This may not be a skuid issue...

Also is the Lightning Team planning on giving error messages that are actually sensible?? I've developed a couple of Lightning Components and the error messages are horribly undescriptive. It seems like the source code uses $A.assert very liberally, which makes for great testing best practices, but a horrible developer experience when trying to figure out what actually broke everything...
Photo of Ken McElrath

Ken McElrath, Official Rep

  • 1,214 Points 1k badge 2x thumb
Moshe, what SF instance are you on? And is this a Sandbox org? The reason I ask is that we just submitted a critical bug to Salesforce about how their latest release has disabled all managed packages in sandbox orgs (not just Skuid). Thus far, this is only affecting certain instances. Last time this happened they fixed it within 24 hours.
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Sandbox on cs45. My skuid page builder is loading fine in the VisualForce view, just not the Lightning view.

P.S. I'm honored to be talking to the big boss :)
Photo of Ken McElrath

Ken McElrath, Official Rep

  • 1,214 Points 1k badge 2x thumb
Thanks. Running this by the engineers and they should get back to you. It's been one of those days with Salesforce. Thankfully, only sandboxes are affected.
Photo of Ken McElrath

Ken McElrath, Official Rep

  • 1,214 Points 1k badge 2x thumb
Just checked and it looks like you've got a Lightning bug on your hands. Best bet is to log a case. Lots of Lightning bugs flying around right now. We have the same issue with their cryptic messages. Nearly impossible to decipher. They usually get around to creating better messages, but right now it seems to be all hands on deck to get a stable Lightning release out the door.
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Thanks for looking into this!
Photo of Glenn Elliott

Glenn Elliott, Champion

  • 7,748 Points 5k badge 2x thumb
Hey Moshe ... did you ever get this working? I'm trying to create my first Lightning app with a Skuid page in it. I'm using the Lightning App Builder (which may be a flawed approach) and there's no Skuid components available there to drop into the page. Curious to know if your approach worked.
Photo of Zach McElrath

Zach McElrath, Employee

  • 50,232 Points 50k badge 2x thumb
Glenn, what version of Skuid are you using? And do you have My Domain enabled in your org?
Photo of Glenn Elliott

Glenn Elliott, Champion

  • 7,748 Points 5k badge 2x thumb
Hey Zach ... I got further just now. I think yesterday I missed the step of deploying My Domain to users. I did that just now and saw the Skuid component in the Lightning App Builder. I dragged it onto the workspace, but then got this error.



I'm on Skuid 7.36.
Photo of Zach McElrath

Zach McElrath, Employee

  • 50,232 Points 50k badge 2x thumb
I think you'll need to file a support case with Salesforce for this one.