Learning Center section navigation is...not right...

  • 1
  • Problem
  • Updated 1 month ago
See here: http://recordit.co/6IjJGYUl5M

There's 2 Ok buttons, both direct to the same page, and I never get credit for completing the section...this seems to be happening on every section I complete :(

On a lighter note, Data in the Big City is a great analogy! I will be using this in the future.
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,270 Points 3k badge 2x thumb

Posted 1 month ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Thanks for the report.  And the video.  I'll look into that functional path through the application and figure out what is going on. 
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Conlan - I've made some tweaks to the rendering which should prevent the "double Ok button" in the popup. 

The other issue is simply query speed.  If you wait on the page before pushing "next" do you ever get the quiz section loaded?  If that happens,  all the subsequent functionality should work.  We were expecting you to read for a while before getting to the bottom and so were querying our records in that order...   You just are too fast for the current architecture. 

As you can imagine this application is testing some of our Spark release features.  Initial work has proven too slow - and we are doing some rearchitecting.  That improvement has yet to be applied to the Learning Center application. Its the problem with dogfood.. 
Photo of Conlan O'Rourke

Conlan O'Rourke

  • 3,270 Points 3k badge 2x thumb
Thanks Rob. The redundant OK button is now gone...but I'm not having any luck with getting to the quiz section. I've let the page sit for a couple of minutes before clicking next, but still being re-directed back to the projects page without receiving credit for completing the section. Installing the sample data set only took me a minute or two (under the Register for Skuid site project), so I can imagine the querying would need to be faster than it currently is for most Learners...and maybe even some kind of conditional rendering rule on the next button that looks at my Skuidsite to see whether I have actually installed the sample data set or not...like Trailhead does...ok, ok I'm getting ahead of myself, and I'm sure you all are working on that already.