Issue Accessing Test Application

  • 1
  • Problem
  • Updated 4 months ago
  • In Progress
Hi, I am trying to use the test application. Here is the error i get....Error retrieving metadata for Model(s) associated with Data Source 'SkuidSample__OData-Demo'. Please check Models' properties to ensure they are set correctly. { "response": { "status": "Bad Request", "statusCode": 400, "headers": { "cache-control": "no-cache", "Content-Type": "application/json; charset=utf-8", "Date": "Tue, 24 Jul 2018 17:12:48 GMT", "Server": "nginx", "Strict-Transport-Security": "max-age=31536000; includeSubDomains", "Content-Length": "136", "Connection": "keep-alive" }, "error": "Error retrieving data source. Check the configuration. Maximum redirections reached", "body": { "statusCode": 502, "error": "Bad Gateway", "message": "Error retrieving data source. Check the configuration. Maximum redirections reached" } } }
Photo of Femi

Femi

  • 80 Points 75 badge 2x thumb

Posted 4 months ago

  • 1
Photo of Khamla Phimmachack

Khamla Phimmachack, Official Rep

  • 1,536 Points 1k badge 2x thumb
Hi Femi,

Can you walk us through your process and let us know where/when you are getting this error? Also, have you cross-referenced our documentation for installing Skuid? https://docs.skuid.com/latest/en/skuid/install.html
Photo of Femi

Femi

  • 80 Points 75 badge 2x thumb
Thanks for the response. I often get this issue at the point of composing the application.Please also find attached the screen shot
Photo of Khamla Phimmachack

Khamla Phimmachack, Official Rep

  • 1,536 Points 1k badge 2x thumb
Femi, what you are seeing is an issue that has been previously reported and we have updated the sample application to fix this. Since you already have the sample app installed, you will need to update your Data Source's URL in Skuid Settings from "http..." to  "https..." to resolve this.