Is it hard to remove table settings icon

  • 1
  • Question
  • Updated 2 years ago
  • Answered
It seems to push the table down a page and I would much rather remove it all together. I can hide it in css but that doesnt fix the spacing
Photo of David Forder

David Forder

  • 2,144 Points 2k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
David,

It sounds like you want to have a table with no elements above the table header.  You just need to uncheck the box 'Allow Users to Show/Hide Column' for every field in your table and then uncheck the box 'Show Search Box' under the table's Filter & Search tab-> Search Properties.  Here is sample XML that demos this for Contacts.

Thanks,

Bill

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" useviewportmeta="true" showsidebar="true" showheader="true" tabtooverride="Contact">    <models>
        <model id="Contact" limit="100" query="true" createrowifnonefound="false" datasourcetype="salesforce" datasource="salesforce" sobject="Contact">
            <fields>
                <field id="FirstName"/>
                <field id="LastName"/>
                <field id="CreatedDate"/>
            </fields>
            <conditions/>
            <actions/>
        </model>
    </models>
    <components>
        <pagetitle model="Contact" uniqueid="sk-1OB6y--94">
            <maintitle>
                <template>{{Model.labelPlural}}</template>
            </maintitle>
            <subtitle>
                <template>Home</template>
            </subtitle>
            <actions>
                <action type="savecancel"/>
            </actions>
        </pagetitle>
        <skootable showconditions="true" showsavecancel="false" searchmethod="server" searchbox="false" showexportbuttons="false" pagesize="10" createrecords="true" model="Contact" mode="read" allowcolumnreordering="false" uniqueid="sk-1OB6y--95" emptysearchbehavior="query">
            <fields>
                <field id="FirstName" hideable="false" allowordering="true" uniqueid="fi-1OB672-373" valuehalign="" type="" showbydefault="false"/>
                <field id="LastName" hideable="false" allowordering="true" uniqueid="fi-1OB672-374" valuehalign="" type="" showbydefault="false"/>
                <field id="CreatedDate" hideable="false" allowordering="true" uniqueid="fi-1OB672-375" valuehalign="" type="" showbydefault="false"/>
            </fields>
            <rowactions>
                <action type="edit"/>
                <action type="delete"/>
            </rowactions>
            <massactions usefirstitemasdefault="true">
                <action type="massupdate"/>
                <action type="massdelete"/>
            </massactions>
            <views>
                <view type="standard"/>
            </views>
            <searchfields/>
        </skootable>
    </components>
    <resources>
        <labels/>
        <css/>
        <javascript/>
    </resources>
    <styles>
        <styleitem type="background" bgtype="none"/>
    </styles>
</skuidpage>
Photo of Matt Small

Matt Small

  • 1,182 Points 1k badge 2x thumb
I would have just used css and made the display value "none"
Photo of David Forder

David Forder

  • 2,144 Points 2k badge 2x thumb
Thats it.. I missed the 'Allow Users to Show/Hide Column" flag ... Thanks )