If Rendering is edited, why wouldn't reversing to a previous version of page bring the XML back to where I started ?

  • 1
  • Problem
  • Updated 4 years ago
  • Not a Problem
I made edits to the rendering of certain components to the page and kept reversing the page to previous versions but ultimately had to copy and paste the entire XML body of code from a sandbox account into my environment to correct the edits made to the page - why is that?
Photo of Yina Chun

Yina Chun

  • 792 Points 500 badge 2x thumb
  • Confused

Posted 4 years ago

  • 1
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
That really shouldn't be happening. Can you reproduce it?
Photo of Yina Chun

Yina Chun

  • 792 Points 500 badge 2x thumb
 Let me try to reproduce it, thank you for your reply!
Photo of Jarrod Hinson

Jarrod Hinson

  • 2,310 Points 2k badge 2x thumb
I have noticed before if you rename your models it messes with the Render Conditions. Maybe you tweaked a model name?
Photo of Yina Chun

Yina Chun

  • 792 Points 500 badge 2x thumb
I could have. I will attempt to reproduce this error. Thank you so much for your reply, I will be sure to keep you posted.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
One thing that tricks people up with versions is that once you have reverted to a prior version.  The page changes in the builder,  but that version is not saved.  So if you revert and then immedately preview - the old version will show. 

So revert,  then save,  and then preview...
Photo of Yina Chun

Yina Chun

  • 792 Points 500 badge 2x thumb
That is good to know. Thank you Rob!
Photo of Yina Chun

Yina Chun

  • 792 Points 500 badge 2x thumb
This has been resolved! Thanks Skuid Team!