icons not showing in page builder drawer

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Pat... any chance you haven't clicked the "Update Themes" button on the Themes page?
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
I hadn't done that yet. It's done now and still have the issue.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Hmm, no idea then.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Pat.  The builder is showing classic icons and your run-time is showing font awesome.  There is some cross coverage (any items in the Standard tab of the icon picker popup works across both sets) but once you are outside those standards - you'll get the error icon.  Change your theme or change your icons... 
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
That's the thing. The theme I'm using, Classic, used the UI Silk icon set.

Icons on the page that are not in a popup show properly.
Icons on the page that are in a popup don't show up properly.

This is in the Page Builder UI.
Photo of mB Roman Melnik

mB Roman Melnik

  • 2,802 Points 2k badge 2x thumb
I've been experiencing a very similar issue since first upgrading to Banzai.

All of my pages use the Classic Skuid Theme and Icon Set, but the icons from the new Composer Themes aren't compatible. So I have to work around a lot of error icons when composing a page, as seen below.

Photo of mB Roman Melnik

mB Roman Melnik

  • 2,802 Points 2k badge 2x thumb
Actually, scratch that. I just realized I haven't been specifying the Classic Theme in the Page Settings. That was silly of me... Sorry for the confusion.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Well well well.  Pat has found a pretty bizarre bug.  But it is indeed a bug.  We'll get it fixed. 
Photo of Tami Lust

Tami Lust

  • 5,280 Points 5k badge 2x thumb
Rob,

We have our pages set to "Default" is there a way to change them all to "Classic" at once?
Photo of Anna Wiersema

Anna Wiersema

  • 10,890 Points 10k badge 2x thumb
Hey Tami, the easiest way is to change your Org Default Theme to Classic in Theme > Theme Assignments > Organization Wide Defaults (that way "default" will mean "classic," unless a user or profile as a different default set).

Will this method work for your purposes?
(Edited)
Photo of Tami Lust

Tami Lust

  • 5,280 Points 5k badge 2x thumb
Hey Anna,

I checked the Org Default Theme section and it is set to the Classic Theme. However, my individual pages show "Default". I have to manually change them to Classic. We don't have any different setting for users or profiles. Do I have to push the "Update Theme" button?
Photo of Anna Wiersema

Anna Wiersema

  • 10,890 Points 10k badge 2x thumb
When you preview a page with "Default" is it showing in the Classic theme?  

"Default" just means that that page will show the default theme for your org. Since the default theme for your org is Classic, all pages with Theme set to "Default,"  will be shown in Classic theme.

If this isn't the case for you, it is possible that you have a different Theme set up for your Profile/User override. You can check this out in Theme > Theme Assignments > Profile/User Overrides.
Photo of Tami Lust

Tami Lust

  • 5,280 Points 5k badge 2x thumb
There is nothing set up under Theme > Theme Assignments > Profile/User Overrides. 
The Default Runtime Theme is: Classic
When I change a page from 'Default' to Classic' the icons come back.
Photo of Anna Wiersema

Anna Wiersema

  • 10,890 Points 10k badge 2x thumb
Oh okay, now I understand what's going on, I'm so sorry; I didn't realize this was still in the context of icons.
(Edited)
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Tami.  This was an issue identified with the package you are running.  When your pages were default, the classic Icons did not show. We are fixing that.  Like in next day. . . 
Photo of Tami Lust

Tami Lust

  • 5,280 Points 5k badge 2x thumb
Thanks Rob! I will be on the look out for the update.
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
This should be fixed in Banzai Update 5. Available from the http://skuidify.com/skuidreleases page.