How to Override Standard Tab

  • 1
  • Question
  • Updated 4 months ago
  • Answered
I'm new to Skuid, so please, be gentle.

I am trying to do my first override. I have created a new Skuid Contacts page. I have gone to Deploy. Here I have added the following:

Contact - Tab - Organization Default - Any Record Type - Contacts - Active

As you can see, I want the new Skuid 'Contacts' page to override the native 'Contact' page.

Everything saves fine. When I try to check by clicking the 'Contact' tab I'm not directed to the Skuid 'Contacts' page I created.

I've been at this for a couple hours now. Any help would be great. I'm sure I'm missing something super small here.

NOTES:
I have completed the following and have permissions:
  • Assign / remove user Licenses to Skuid (needed for anyone who will be using Skuid in any way)
  • Assign users the Skuid Page Viewer Permission Set (needed for anyone who will be using Skuid in any way)
  • Assign users the Skuid Page Builder Permission Set (needed for all users who will be creating / editing Skuid Pages)
  • Assign users the Skuid Admin Permission Set (needed to manage Skuid Settings and deploy Pages using Page Assignments ) 
I have also previewed my new page and it works as expected.
Photo of Paul Karaffa

Paul Karaffa

  • 70 Points
  • frustrated

Posted 4 months ago

  • 1
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Paul,

Welcome!

I think you are using the Classic interface.  If you are using Lightning, then please check here for what you need to do:  https://docs.skuid.com/latest/en/skuid/deploy/salesforce/lightning/

I think you need to add a VisualForce page to override the standard tab that Salesforce will normally show.  You also need to 'link' this VisualForce page to the 'Tab' action for the Contact object.  Check here for details on what to put into your VisualForce page and how to override the 'Tab' action: https://docs.skuid.com/latest/en/skuid/deploy/salesforce/visualforce/

Thanks,

Bill