hidden render field not showing in drawer

  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
I have a field in a drawer that is rendered hidden unless another field = "Other".  If the field is "Other" when the drawer is opened, then the rendered field is shown.  If I then select something besides that "Other", the field does not show.  This all works correctly.

If I start without "Other" being selected the field is rendered hidden.  That works correctly.

However, if the field is initially rendered hidden and I then select "Other" the field the hidden does show and it should show.

Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
I'm guessing there is a typo in your last line and you meant to say:  
"If the field is initially hidden and I select "Other" the field DOES NOT render" 

Is the field where you select "Other" on the same mode and row in context?  (Do you have context conditions applied?)  Is the Field that is hidden on the same model as the table it is under?  (Do you have its contenxt conditions applied? )
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
Yes it is on the same row.  The one is a reference field:

And the "Other Name" is a field in the same object, Social_Site_DNA__c
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
And what does the context for the components in the drawer look like? 
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
There are none?