Google calendar error - SSL is required

  • 2
  • Problem
  • Updated 2 years ago
  • In Progress
Hi,

I followed the Google Calendar tutorial closely and can't figure out this error message below. I have my email address as the calendarId. Any ideas what I'm doing wrong?

Thanks,
Chelsea

Photo of Chelsea Curtis

Chelsea Curtis

  • 1,300 Points 1k badge 2x thumb

Posted 2 years ago

  • 2
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Chelsea,

Try switching the calendarId URL merge condition to filterable default on, and put your email in as the value. In the page builder can you view the fields of the CalendarList model?

Thanks!
Amy
Photo of Chelsea Curtis

Chelsea Curtis

  • 1,300 Points 1k badge 2x thumb
Hi Amy,

We already had the condition set to filterable default on.... We are not able to access the fields because of this error message. Here's another look.

We had a test page working with the google calendar a few months ago. The only change I can think of would have been us updating the version of Skuid.

Any other ideas why this would be happening? What's it mean by "Forbidden: SSL is required..."?



Thanks!
Chelsea
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Chelsea,

I think the problem is in the url of your data source. Check that you're using "https://www.googleapis.com" (as opposed to "http://www.googleapis.com"). That "s" after the http tells your request to Google Calendar to go through a Secure Socket Layer (SSL). The Secure Socket Layer is used to more securely pass data between a client (in this case your browser) and a web server (such as Google Calendar). Here are screenshots of my setup in case that's not the problem:

Authentication Provider:


Data Source:


Under data source, my URL Parameters, Headers, Body parameters, and Client Certificate options on the right side are blank/empty. 

Thanks!
Amy
Photo of Chelsea Curtis

Chelsea Curtis

  • 1,300 Points 1k badge 2x thumb
Hi Amy,

Thanks for your help! Yes, it looked like human error on my part... I forgot the "s" in one area. This gave me a new error message where I had to enable the Google Calendar API in the Dev Console - something I didn't have to do before.

Still not getting what I need. The data will not populate in a Calendar Component. I noticed a few things as I dug in:
  1. In the tutorial, it says that UPDATE should have a service access method of "POST", but I think it should be "PATCH". Is that correct?

  2. I am not able to render any calendar events within the Calendar Component, however when I throw the GoogleCalendar model in a table, it shows events successfully.

    Screenshot of the bottom of a table with 249 records, but nothing populating in Calendar:

    Screenshot of my event source setup:


  3. When I create a new event, it happens successfully and shows on the Calendar Component. But when I refresh the page, it's no longer in the Calendar Component. It still appears in my Google Calendar.

  4. Why is the Summary field listed as a Date? This was not allowing the data to pass until I manually updated it to "Text":


  5. My Common Request Parameters are different than your screenshot. I did not add this, it populated automatically when I selected Google. Should I delete it to match yours or not?

Thanks!
Chelsea
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Chelsea,

I don't have all the answers to your questions, so I'm asking another person on my team about them, but I'll answer the questions that I can, at least. 

1. I also only got PATCH to work, but I'm not sure if that's correct or not
2. You should be able to see at least some of your events in your calendar, although I don't see most of my reoccurring events. I'm sure you do, but make sure your start and end field are start.dateTime and end.dateTime respectively. Do you see anything if you switch the views around between month and week?
3. I see this behavior as well, but I don't know what's causing it or how to fix it
4. My Summary field loaded as a String so I'm not sure why yours didn't
5. You should have that parameter, and you want to keep it. It is automatically created by Skuid and is how you get authenticated to Google

Thanks!
Amy
(Edited)
Photo of Chelsea Curtis

Chelsea Curtis

  • 1,300 Points 1k badge 2x thumb
Thanks Amy. 

2: Yes, I have the start and end fields filled out on the Event source. And it will not work for Month or Week views.

Look forward to getting more answers on this. Happy to provide Skuid with login access if that helps.

Thanks,
Chelsea
Photo of Chelsea Curtis

Chelsea Curtis

  • 1,300 Points 1k badge 2x thumb
Hi Amy,

Any followup on this? We are at a standstill and we would like to get this implemented.

Thanks,
Chelsea