Getting LinkedIn Sales Navigator for Salesforce VisualForce Page to display in a Skuid template

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I'm trying to get the LinkedIn Sales Navigator for Salesforce VisualForce page to display in an iframe. Here is the iframe code I am using in a Skuid template and I have "allow HTML" checkbox checked.
<iframe src="/apex/lid__ContactLinkedInMemberPage?id={{{Id}}}&isdtp=mn" width="70%" height="400"></iframe>
I am passing the Contact Id into the VisualForce page.

When I go to view the iframe within a Skuid page it is showing up as blank (can't see the widget load). However, if I inspect the HTML and get the URL from the iframe and preview the VisualForce page I can see the widget. Here is the URL I am previewing, which works.

https://lid.na54.visual.force.com/apex/ContactLinkedInMemberPage?id=0030a00001WTaQRAA1&isdtp=mn

Is there something obvious I am missing here? Anyone else have experience with the LinkedIn Sales Navigator for Salesforce VisualForce page? It's odd since I've done other VisualForce pages the same way and they have always worked.

Any help is greatly appreciated.

Andrew
Photo of Andrew N

Andrew N

  • 1,178 Points 1k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Andrew,

Are you there any errors in your browser developer console (in Chrome: right-click the page and select Inspect, then look at the Console tab) when you preview the Skuid page? 
Photo of Andrew N

Andrew N

  • 1,178 Points 1k badge 2x thumb
Amy - thanks for the reply, but I was able to figure out the issue.

For anyone else trying to put a VisualForce page into an iFrame and the VisualForce page is coming up black here is a potential solution.

Salesforce has a feature called Clickjack Protection which I believe is designed to prevent malicious links being displayed through an iFrame to Salesforce users. To access Clickjack Protection go to Setup -> Security Controls -> Session Sharing -> Clickjack Protection.


Salesforce requires the first two settings be Enabled by default. However, it is the second two settings that, if Enabled, can cause issues with putting a VisualForce page into an iFrame within a Skuid Template.

In my case the last option was Enabled and the LinkedIn Sales Navigator for Salesforce VisualForce page had showHeader="false", so it was getting blocked. Turning off this feature fixed the issue and the iFrame worked as expected.

Hopefully this helps anyone else running into this issue in the future.

Andrew