force.com site not loading

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
I've gone through the steps outlined in Skuid tutorials, shared skuid with the guest user, and double checked the public access requirements, but can't seem to figure out why I'm receiving a blank page.

I'm using the <skuid: page> approach for the site.

This is the error I receive:


Any help is much appreciated!
Photo of Chelsea Curtis

Chelsea Curtis

  • 1,300 Points 1k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,004 Points 20k badge 2x thumb
Make sure your Site Guest User has Read-Only access to the Page records you want to make visible on the Force.com Site:

1. Go to the Page Composer for each of the Skuid Page records that you want to expose on the Force.com Site.
2. Click the "Share" button.
3. Click "Add".
4. Search "Users" for "Site Guest User".
5. Click the name of your Site's Guest User record and click the arrow to move them into the Share With column.
6. Select "Read Only".

Click Save.
Photo of Chelsea Curtis

Chelsea Curtis

  • 1,300 Points 1k badge 2x thumb
Perfect. Thank you, Zach!! Is this something new that must be done? I've gone through the same process before with another force.com site in a different org and I did not have to share the actual skuid page with the guest user.

Thanks again for the quick response.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,004 Points 20k badge 2x thumb
It all depends on your org's Sharing Settings for the Skuid Page object. If the Org Wide Defaults were set to Public Read Only in your other org that you did this in, then you wouldn't have had to do this. If your Org Wide Defaults are Private, though, or if you have a separate External Sharing Model where Page object is Private, then you have to do this.