Filter removal and apply make the page slow and some time sticked

  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
Whenever user applied filter to the SKUID list view following behavior occurs.
some time page load correctly and some times it get stuck or displays message applying filters.
Some time the page doesn't even load. 
Photo of Ravi Mandowra

Ravi Mandowra

  • 386 Points 250 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Emily Davis

Emily Davis, Employee

  • 3,502 Points 3k badge 2x thumb
Ravi,
That is interesting. What kind of error message are you getting? Are you using any custom JavaScript code in your page? What version of Skuid do you have installed?  Do you know how to check the developer console for JavaScript errors? Also, it might help to send some screenshots or your a copy of your page xml to support@skuidify.com.
Emily
Photo of Ravi Mandowra

Ravi Mandowra

  • 386 Points 250 badge 2x thumb
Hi Emily,

Sure, will send you the XML, We are not using any custom JS. I am wondering because some time it works perfect and some time its take more than a min and still doesn't come up. 
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Ravi,  a few things here:

1.  If you see the message "applying filters"  that means the query is progressing.  Be patient and it may completed. 

2. If the "applying filters" message gets stuck - look in the browser console and you will probably see a Javascript Remoting error.  What is happening is that the requery action is timing out.  This Requery is using Javascript Remoting which has somwhat different time out rules than what is used on initial page load.  Even if the query is processing on the salesforce servers - the remoting processes might still time out.  At this point all you can do is refresh your page. 

What is most frustrating about this issue is that caching makes queries work really well the second time you try.  So you might time out on first attempt,  but have no problems trying to reproduce the issue because salesforce has cached the query.  

We are working to both improve the query time and provide better user feedback with these time-outs occur.  Stay tuned.  
Photo of Ravi Mandowra

Ravi Mandowra

  • 386 Points 250 badge 2x thumb
Thanks Rob

It is also happening for the user for the initial page load as well, will try to get the screen shot of it..
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
If you are able to work with this user toward getting a screenshot, can you ask them to expose the browser console to see if there are any error messages?